Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Функция со случ. выбором из текстовых значений

Автор kim k., 20.05.2011, 15:56

« назад - далее »

kim k.

Добрый день!
подскажите пож., какая функциея осуществляет случайный выбор из трех или больше текстовых значений?
Пример: Имеем значения:
"АвтоЗаз"
"ВАЗ"
"Daewoo"
Какая из функций умеет выбирать random из них?

Спасибо!

Serge 007

Здравствуйте.

=ИНДЕКС(A1:A10;СЛЧИС()*10)
=ИНДЕКС(A1:A10;СЛУЧМЕЖДУ(1;10))
Данные в A1:A10.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

kim k.

О! спасибо! интересное решеение с ИДНЕКС()!
а отдельной функции для текста нет --  как СЛУЧМЕЖДУ() для чисел?

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

_Boroda_

Еще вариант
=ВЫБОР(СЛУЧМЕЖДУ(1;3);"АвтоЗаз";"ВАЗ";"Daewoo")
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

kim k.

#5
ВО!!! оно!!!! я помню, что был подобный способ! Спасибо, _Boroda_ и Serge 007!
Теперь я вдвойне вооружен, хехе)))