Как посчитать среднее время?

Автор Stable, 30.05.2011, 15:42

« назад - далее »

Stable

Здравствуйте!
Уже просмотрела кучу форумов и тем, но так и нашла то, что нужно.
Задача: дан массив времени в формате Ч:ММ:СС, надо найти среднее время.
Пробовала через СРЗНАЧ, получается неверное значение.
Еще так пробовала.
=МИН(СУММ(F10:F90))/H159. Суммировала все значения, переводила в минуты, делила на кол-во значений.
Need help!

Василий Алибабаевич

Приведите пример, как правильно считать:

Например:
10:15:00
13:45:00
18:10:00

какой время будет средним?

я правильно понимаю, что нужно найти среднее время течения какого-то процесса? если да, то я проверил, срзнач() корректно работает.

Stable

Приложила файл. Нужно посчитать среднюю длину сессии(временного интервала).
Зеленым выделила группу ячеек, среднее значение для которых нахожу. А также зеленым ячейку с формулой - через СРЗНАЧ, которое получилось больше чем максимальное значение в этой группе.

Stable

Прочитала вот такое.
Нюанс здесь только один. Если при сложении нескольких временных интервалов сумма получилась больше 24 часов, то Excel обнулит ее и начнет суммировать опять с нуля. Чтобы этого не происходило, нужно применить к итоговой ячейке формат 37:30:55 (меню Формат - Ячейки - Число - Время)
Видимо проблема из-за этого. :o

_Boroda_

В столбец F напишите формулу
=ПСТР(B2;13;5)-ПСТР(A2;13;5)
или, если дни могут быть разными, то
=ПСТР(B2;13;5)-ПСТР(A2;13;5)+ПСТР(B2;2;10)-ПСТР(A2;2;10)

У Вас в F не только время, но еще и 6 дней
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

MCH

F2 и ниже формулу:
=ПСТР(B2;2;19)-ПСТР(A2;2;19)
и СРЗНАЧ будет корректно работать

или в L2 формулу массива (вводится нажатием контрл+шифт+ентер):
=СРЗНАЧ(ОСТАТ(F2:F9;1))

Stable

Спасибо, _Boroda_ и MCH! ;)
Действительно, все заработало!!!