Факторный анализ (умножение по 2-м условиям) не VBA

Автор turentoo, 06.06.2011, 10:05

« назад - далее »

turentoo

Здравствуйте.

Я уже что только ни пробовала, может вы поможете.

Есть, 4 столбца. В первом месяц, во втором имя человека, в третьем и четвертом цифры.
Например:
май -- петров --4--6
Июнь -- петров--5--2
май -- иванов --5--1
Июнь -- иванов -- 1--2

Нужно сделать (не VBA, а формулой в ячейке) следующий подсчет:

для каждого работника с месяцем Май умножить первый столбик с числами на второй столбик с числами этого же работника в месяце Июнь и сложить результаты.

Т.е.: 4*2+5*2=18

Хотя бы подскажите, какими функциями можно попробовать, 2 часа уже бьюсь с этим... :'(

Serge 007

Здравствуйте.

Можно так:
=СУММПРОИЗВ((A1:A4="май")*C1:C4*(A2:A5="июнь")*D2:D5)
но всегда лучше прикладывать пример.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

turentoo

К сожалению, Ваше решение не учитывает имена сотрудников..


Serge 007

Ну так рисуйте нормальный пример в xls, с внятным объяснением.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

turentoo

Цитата: Serge 007 от 06.06.2011, 10:49
Ну так рисуйте нормальный пример в xls, с внятным объяснением.

Извините.

Вот файл с примером и некоторым оъяснением. Произведение должно учитывать имена сотрудников.

Serge 007

Понятнее стало не намного :)
Каким образом надо учитывать фамилии?
В итоге то показатели всё-равно суммируются по обеим?
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

turentoo

В каждом месяце работает несколько человек.
Для каждого человека нужно умножить первую числовую колонку за первый месяц на вторую числовую колонку за второй месяц и сложить значения.

То есть:

май--иванов--2--3
май--петров--1--4
май--сидоров--5--6
июнь--сидоров--7--8
июнь--иванов--1--3
июнь--петров--5--6

мы для иванова будем иметь: 2*3=6
для петрова: 1*6=6
для сидорова: 5*8=40

ИТОГО=6+6+40=52

Serge 007

Как понял:
=СУММПРОИЗВ((A2:A5="may")*(B2:B5="q")*C2:C5)*СУММПРОИЗВ((A2:A5="june")*(B2:B5="q")*D2:D5)+СУММПРОИЗВ((A2:A5="may")*(B2:B5="w")*C2:C5)*СУММПРОИЗВ((A2:A5="june")*(B2:B5="w")*D2:D5)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

turentoo

Цитата: Serge 007 от 06.06.2011, 11:29
Как понял:
=СУММПРОИЗВ((A2:A5="may")*(B2:B5="q")*C2:C5)*СУММПРОИЗВ((A2:A5="june")*(B2:B5="q")*D2:D5)+СУММПРОИЗВ((A2:A5="may")*(B2:B5="w")*C2:C5)*СУММПРОИЗВ((A2:A5="june")*(B2:B5="w")*D2:D5)

Да, Вы поняли абсолютно верно!
Только у меня простыня с данными на 260 строк вниз и имен там очень много, вручную всех так не пропишешь.. Хотелось бы автоматизировать  :(

Serge 007

Цитата: turentoo от 06.06.2011, 11:37
Только у меня простыня с данными на 260 строк вниз и имен там очень много, вручную всех так не пропишешь.. Хотелось бы автоматизировать  :(
С этого начинать надо было :)
С доп вычислениями можно.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390