Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Главное меню

формула и ее доработка

Автор graffserg, 08.06.2011, 00:12

« назад - далее »

graffserg

Уважаемые знатоки!
Помогите решить маленькую проблемку:
Существует файл, в нем несколько листов:
1 - обобщенные данные;
2 - информирование, который состоит из: № п/п; работник; дата; предприятие; что предпринималось; примечание;
3 - ввод данных.
Мне необходимо:
1. с помощью формулы сделать так, чтобы работа каждого сотрудника отражалась по месяцам, а потом суммировалась?
Использовал формулы:
- =ЕСЛИ((СЧЁТЕСЛИМН(Информирования!D2:D600;"="&A3;Информирования!B2:B600;"="&O1))=0;"";(СЧЁТЕСЛИМН(Информирования!D2:D600;"="&A3;Информирования!B2:B600;"="&O1))) - давала общее количество по каждому сотруднику по предприятиям
- =ЕСЛИ((СЧЁТЕСЛИМН(Информирования!G2:G600;"=1";Информирования!B2:B600;"="&N1))=0;"";(СЧЁТЕСЛИМН(Информирования!G2:G600;"=1";Информирования!B2:B600;"="&N1))), давала, количество по месяцам, но все количество сосредотачивалось в одном предприятии, а нужно наоборот.

2. данные имеются за декабрь 2010 года, а с использованием формулы =ЕСЛИ((СЧЁТЕСЛИМН(Информирования!G2:G600;"=12";Информирования!B2:B600;"="&O1))=0;"";(СЧЁТЕСЛИМН(Информирования!G2:G600;"=12";Информирования!B2:B600;"="&O1))), они прописываются в 2011 год, как можно распределить по годам?

3. ....G2:G600;.....B2:B600; - фиксированные графы для каждого из сотрудников, ..&N1, &О1.. обозначают графу сотрудника, как сделать так, чтобы  ....G2:G600;.....B2:B600; были неизменны, а ..&N1, &О1.. изменялись для каждого сотрудника отдельно???

Serge 007

Сводной таблицей
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390