Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Главное меню

задача с совпадающими ячейками

Автор ovetskiy, 15.06.2011, 15:35

« назад - далее »

ovetskiy

есть два столбца с совпадающими в разных строках ячейками
задача в том, чтобы эти ячейки отображались в одной строке в соседних ячейках
спасибо

Serge 007

См. вложение.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

ovetskiy

Вы извините
я, видимо, неквалифицированно поставил задачу
имеется в виду следующее:
есть конструкция

1   4
2   3
3   2
4   1
5                                    0
а получить надо

1   1
2   2
3   3
4   4
5   0

совпадающие ячейки условно отформатированы

спасибо

Serge 007

#3
Цитата: ovetskiy от 15.06.2011, 17:07
я, видимо, неквалифицированно поставил задачу
Это:
Цитата: ovetskiy от 15.06.2011, 15:35
задача в том, чтобы эти ячейки отображались в одной строке в соседних ячейках
кто писал?

ВСЕГДА прикладывайте файл пример. Тогда текст практически не нужен и ошибок можно избежать.

По теме: В формуле замените СТОЛБЕЦ(А1) на СТРОКА().

ЗЫ Формулы массива вводятся нажатием Ctrl+Shift+Enter
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

nilem

Так попробуйте:
Sub rtyrty()
Dim x, y(), i&, j&
x = Range("A1:B" & Cells(Rows.Count, 1).End(xlUp).Row).Value
ReDim y(1 To UBound(x), 1 To 1)

For i = 1 To UBound(x)
    For j = 1 To UBound(x)
        If x(i, 1) = x(j, 2) Then y(i, 1) = x(j, 2): Exit For
    Next j
    If j > UBound(x) Then y(i, 1) = x(i, 2)
Next i
[b1].Resize(i - 1).Value = y
End Sub

_Boroda_

Если я правильно понял вопрос, то можно так:
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A1;$B$1:$B$5;0));A1;0)
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995