Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Суммирование по условию из нескольких колонок таблицы

Автор Елена.Кузнецова, 23.06.2011, 17:36

« назад - далее »

Елена.Кузнецова

Помогите чайнику правильно написать формулу! Надо суммировать по одному условию из нескольких столбцов таблицы. Я это делаю, по-видимому, криво. Пишу двойное суммирование: =СУММЕСЛИ($E$4:$E$15;$A23;$H$4:$H$15)+СУММЕСЛИ($J$4:$J$15;$A23;$M$4:$M$15). Все работает, но сделано громоздко. По-другому не выходит.

Serge 007

Цитата: Елена.Кузнецова от 23.06.2011, 17:36
По-другому не выходит.
При таком расположении данных? Конечно не выходит.

Вот одной формулой:
=СУММПРОИЗВ(($E$4:$E$15=A23)*($H$4:$H$15)+($J$4:$J$15=A23)*$M$4:$M$15)
, но Ваша даже лучше по быстродействию будет.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Serge 007

Ещё так можно:
=СУММ(ЕСЛИ($E$4:$J$15=A23;$H$4:$M$15))
формула массива, вводится нажатием Ctrl+Shift+Enter.

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

DV68

Можно и так:
=СУММЕСЛИ(E$4:J$15;A23;H$4:M$15)
но лучше оставьте как есть

Елена.Кузнецова

Спасибо за помощь! Не знала, что можно использовать СУММПРОИЗВ в данном случае. А в смысле быстродействия - на моих не очень больших объемах пока проблем не было.