Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Проблема с обновлением данных ( используется формула впр)

Автор iva3959, 24.06.2011, 10:37

« назад - далее »

iva3959

Добрый день всем.
Столкнулся с такой проблемой:
У меня два разных листа Excel  назовем их Остатки и Продажи.
В листе продажи прописана формула ВПР которая ссылается на лист остатки, данные в листе остатки обновляются каждый день.
Проблема в том, что данные в листе продажи обновляются, только если эти два файла открыты. Я бы хотел чтобы данные в листе продажи обновлялись автоматически при открытия файла, в не зависимости от того открыт лист остатки или нет.


cheshiki1

Пропиши полный путь к файлу.Что то типа этого =ВПР(D5;'F:\уроки Excel\1\связь двух книг\1\[Образец прайс-листа.xls]Прайс-лист'!$C$4:$E$79;3;ЛОЖЬ). Вроде должно помочь. Но с примером было бы проще.

PS путь должен быть постоянным.

iva3959

путь же автоматически прописывается когда я формулу и ссылаюсь на это лист

cheshiki1

#3
отключи запрос на обновление связей и включи автоматическое обновление.
Данные-Подключения-Изменить связи. для 2007.

iva3959

Спасибо большое, но я сделал чуть по другому. Другие команды-центр управлению безопасности-параметры цетра управления безопасности-включить автоматическое обновление для всех связий книге.