Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Изменение значений функциии в зависимсоти от колонки

Автор Adar, 29.06.2011, 10:10

« назад - далее »

Adar

Создавал тему месяц назад, но не нашёл её, поэтому спрошу ещё раз.

Как сделать чтобы в зависимости от значений в ячейке А1, в конкретной функции менялся диапазон. Например в ячейке А1 значение 10 и диапазон в функции В1:В10, изменив значение в ячейке А1 с 10 на 5 - диапазон меняется на В1:В5

_Boroda_

#1
Самые простые для понимания, на мой взгляд, варианты (не значит, что самые быстрые)
=СУММ(ДВССЫЛ("B1:B"&A1))
=СУММ(СМЕЩ(B1;;;A1))

СУММ - это для примера, можно другую функцию
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

irri

вроде что-то есть, чтобы ставить вместо номера строки (В10 - 10 номер строки) значение из определенной ячейки.

Adar

пример функция

=IF(C27="","",MIN(C27:C89))

я подставил:

=IF(C27="","",MIN(OFFSET(C27,,,89)))

я так понимаю таким образом я должен  получать одинаковые значения? Но я их не получаю

Serge 007

Цитата: Adar от 29.06.2011, 16:42
таким образом я должен  получать одинаковые значения? Но я их не получаю
См. вложение.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

_Boroda_

=IF(C27="","",MIN(OFFSET(C27,,,89-27)))
или
=IF(C27="","",MIN(OFFSET(C1,27-1,,89-27)))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

DV68


Adar

Цитата: Serge 007 от 29.06.2011, 17:03
Цитата: Adar от 29.06.2011, 16:42
таким образом я должен  получать одинаковые значения? Но я их не получаю
См. вложение.

А если мне надо протянуть колноку вниз с функцией и расстояние должно сохраняться: 52 строки, то достаточно того что
MIN(OFFSET(C3,,,$Q$13))

c3 меняется на c4 а в q13 прописано 52? и тогда с С3 до С54 будет смещаться на с4 до 55?