Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Главное меню

Выбор последнего значения из списка?

Автор mros, 01.07.2011, 09:59

« назад - далее »

mros

Форумчане, нужна помощь.
Есть числовой список из 200 позиций в одном столбце. Пока заполнены только первые 50 строк, но список будет дополняться до 200 строк. Как выбрать последнее (50-е), не нулевое значение? Ну и дальше по мере заполнения списка (51,52 и т.д.)?

MCH


Serge 007

Исключать "нулевые значения" или "пустые ячейки"? В списке есть пустые строки или нет?
Пример давайте.

Пока такой вариант:
=ВПР(9E+307;A1:A200;1)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

mros

Спасибо за ответы.
Но что-то не работает:(. Пример приложил. Пустых строк нет, есть только нулевые значения. А что значит/делает выражение 9E+307?

Serge 007

Цитата: mros от 01.07.2011, 11:24
Что значит/делает выражение 9E+307?
Это число. Очень большое :)

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

mros

Клево!!!!
Супер, спасибо, Serge 007, огромное!!!!! Работает!

MCH

для данных чисел (больше единицы):
=ПРОСМОТР(1;1/A1:A200;A1:A200)
для любых чисел:
=ПРОСМОТР(9E+307;1/A1:A200;A1:A200)

mros

Красотень. Не ожиданно просто и изящно. Спасибо!!!

mros

А можете объяснить как эта мистика работает:)? Голову сломал, хэлп по функции перечитал - не доходит до меня понимание этого чуда.....

Serge 007

Цитата: mros от 05.07.2011, 08:54
А можете объяснить как эта мистика работает:)?...не доходит до меня понимание этого чуда...
Это которое?
Если мой вариант, то так:
При помощи функции ЕСЛИ отбираем номера строк содержащих числа;
при помощи функции МАКС находим номер последней строки;
при помощи функции ИНДЕКС возвращаем значение этой последней строки.

Если Вы про вариант MCH, то:
При помощи деления единицы на массив данных получаем результирующий массив из чисел и значений ошибки (если в исходном массиве не число);
функция ПРОСМОТР игнорирует значения ошибки и возвращает последнее значение.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

mros

Спасибо. Тучи прояснились:). Поистине у excel такие глубины о которых и не догадывался...