Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

выборка равных значений

Автор art117, 09.07.2011, 13:57

« назад - далее »

art117

Добрый день уважаемые форумчане!
Возникла задача вот такого характера: имеется три столбца, в одном время в другом число, необходимо провести анализ по столбцу времени найти совпадающее время.
Значения по времени(1 столбец) и из соответствующего этому времени  ячейке из 3-его столбца столбца записать в другую таблицу по соответствующему 2-му критерию (2 столбец) критерию. и эти равные значения выделить каким нибудь цветом. Совпадающие по номеру значения (из 3-го столбца суммируются) суммируются. И записываются в отдельную таблицу.
В прикрепленном файле пример.

PS: Народ очень нужна формула , каждый день сталкиваюсь с этой задачей, очень много данных в таблице, регулярно ошибаюсь. Только начинаю большое плаванье в Еxcel.

Михаил С.

Может Вам это нужно?
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

art117

Большое спасибо.
Почти то что надо, Только надо чтобы в итоговой таблице не было тех цифр время которых не повторяется

art117

Чуток по другому сформулирую вопрос.
нашел формулу .
но не знаю как "попросить многоуважаемый Ексель" искать в столбце одинаковое время (как задать интервал чтобы сравнивал ячейки со временем в одно столбце)

art117

Как задать условия для выборки одинаковых значений в столбике. Народ ХЕЛЛЛППППП!!!!!

DV68

H8:
=СУММПРОИЗВ((СЧЁТЕСЛИ($C3:$C30;$C3:$C30)>1)*($D3:$D30=H3)*$E3:$E30)

art117

Цитата: Dmitr68 от 09.07.2011, 16:11
H8:
=СУММПРОИЗВ((СЧЁТЕСЛИ($C3:$C30;$C3:$C30)>1)*($D3:$D30=H3)*$E3:$E30)

Если не затруднит покажите на примере.
Прикрепленный файл в начале ветки

DV68

Ну да, там стиль ссылок другой:
=СУММПРОИЗВ((СЧЁТЕСЛИ(R[-5]C3:R[22]C3;R[-5]C3:R[22]C3)>1)*(R[-5]C4:R[22]C4=R[-5]C)*R[-5]C5:R[22]C5)

art117

Цитата: Dmitr68 от 09.07.2011, 18:51
Ну да, там стиль ссылок другой:
=СУММПРОИЗВ((СЧЁТЕСЛИ(R[-5]C3:R[22]C3;R[-5]C3:R[22]C3)>1)*(R[-5]C4:R[22]C4=R[-5]C)*R[-5]C5:R[22]C5)
Снимаю шляпу!!! Спасибо!!!
Если Вас не затруднит подскажите пожалуйста как будет выглядеть формула (решения) в случае усложнения задачи.
Если в подобной таблице добавиться следующее условие :
после нахождения одинаковых чисел, проводить суммацию числовых значений по критерию столбика "номера" тех чисел которые стоят раньше по времени.
постараюсь на примере по критерию столбика 2 числу "2" повторяется при значении времени 14:27:31
но раньше осталось 14:26:31   2   17 и это значение отобразилось под прежними суммированными значениями. и соответствеено 17 отображается. Прежние суммированные значения повторяющихся по времени не учитываются.

DV68

#9
Раз десять прочитал, но так ничего и не понял. :-\

Может быть так?:

art117

Цитата: Dmitr68 от 10.07.2011, 04:33
Раз десять прочитал, но так ничего и не понял. :-\

Может быть так?:
отписал в личку