Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Excel 2003.Автоматический ввод поправок из одной таблицы в другую

Автор ket@ru, 19.07.2011, 09:51

« назад - далее »

ket@ru

Здравствуйте! Помогите составить формулу для подстановки в ячейки таблицы данные из другой таблицы( поправки). Я использовала формулу(=ВПР(ОКРУГЛ(C13*2;0)/2;$A$1:$G$6;ПОИСКПОЗ(ОКРУГЛ(D9*2;0)/2;$A$1:$G$1)), но дынные не всегда верные подставляются.Я думаю ошибка в округл. Заранее благодарю. ket@ru

_Boroda_

Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

cheshiki1

не вижу значение "Интервальный просмотр". Он может влиять на правильность выбора. Файл не смотрел пишу по напечатанной формуле.

Михаил С.

Что-то типа такого:
=ВПР(ОКРУГЛ(C25/2;0)*2;$A$1:$G$6;ПОИСКПОЗ(ОКРУГЛ(C26/5;0)*5;$A$1:$G$1;0))
однако непонятно, почему а Вас 3 округляется до 2, а не до 4...
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

_Boroda_

Цитироватьоднако непонятно, почему а Вас 3 округляется до 2, а не до 4...
Во-во!
Именно поэтому и нужно объяснение словами
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

cheshiki1

Дело не в округлении. Просто ВПР при не полном совпадении берет значение раньше (первее, выше) заданного. т.е. в вашем случае при подсчете получается 178,5 впр не находит точно совпадения и берет ближайшее низшее 175.
И согласен с _Boroda_, Михаил С. почему так округлять.

ket@ru

Такой принцып выбора. В А1:А6 ровно середина интервала выбор большего значения поправки  а это всегда  ячейка выше, а уже 3,1 выбор как 4. Так же и на пять и на семь и т.д. Вот в этом то у меня и загвоздка. Сама не чего не могу  придумать, помогите пожалуйста. Ket@ru

cheshiki1

Не совсем понятно. но проверте этот вариант:
=ВПР(ОКРУГЛВНИЗ(C25;0);$A$1:$G$6;ПОИСКПОЗ(ОКРУГЛТ(C26;5);$A$1:$G$1)) для ячейки D26

ket@ru

Цитата: cheshiki1 от 20.07.2011, 17:14
Не совсем понятно. но проверте этот вариант:
=ВПР(ОКРУГЛВНИЗ(C25;0);$A$1:$G$6;ПОИСКПОЗ(ОКРУГЛТ(C26;5);$A$1:$G$1)) для ячейки D26
Спасибо большое! Проверила, в большинстве случаев поправка верная подставляется, но не всегда. А необходимо стопроцентно точное  введение.

ket@ru

Цитата: Михаил С. от 19.07.2011, 12:00
Что-то типа такого:
=ВПР(ОКРУГЛ(C25/2;0)*2;$A$1:$G$6;ПОИСКПОЗ(ОКРУГЛ(C26/5;0)*5;$A$1:$G$1;0))
однако непонятно, почему а Вас 3 округляется до 2, а не до 4...
Спасибо большое! Тоже пробывала формулу. И опять же в большей части вводится верная поправка но иногда и осечка случается. Может попробывать формулу с Если.

cheshiki1

можно и "если" но для этого нужно точно знать в какую сторону когда округлять.

_Boroda_

А так
если 3 должно округляться до 4
=ИНДЕКС($B$2:$G$6;ПОИСКПОЗ(ОКРУГЛТ(C25;2);$A$2:$A$6;0);ПОИСКПОЗ(ОКРУГЛТ(C26;5);$B$1:$G$1;0))
если 3 должно округляться до 2
=ИНДЕКС($B$2:$G$6;ПОИСКПОЗ(ОКРУГЛТ(C25-1E-14;2);$A$2:$A$6;0);ПОИСКПОЗ(ОКРУГЛТ(C26-1E-14;5);$B$1:$G$1;0))

А вообще - что мы тут угадываем, а Вы нас общими словами кормите?
ЦитироватьПроверила, в большинстве случаев поправка верная подставляется, но не всегда.
ЦитироватьИ опять же в большей части вводится верная поправка но иногда и осечка случается
Где примеры того что "сечется"?
кладите четкое объяснение ПОЧЕМУ при таких-то числах должен быть такой-то коэффициент.
Не можете словами - кладите таблицу с четырьмя столбцами
Число1; Число2; Коэф; ПОЧЕМУ такой коэф
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

ket@ru

Цитата: _Boroda_ от 22.07.2011, 01:43
А так
если 3 должно округляться до 4
=ИНДЕКС($B$2:$G$6;ПОИСКПОЗ(ОКРУГЛТ(C25;2);$A$2:$A$6;0);ПОИСКПОЗ(ОКРУГЛТ(C26;5);$B$1:$G$1;0))
если 3 должно округляться до 2
=ИНДЕКС($B$2:$G$6;ПОИСКПОЗ(ОКРУГЛТ(C25-1E-14;2);$A$2:$A$6;0);ПОИСКПОЗ(ОКРУГЛТ(C26-1E-14;5);$B$1:$G$1;0))

А вообще - что мы тут угадываем, а Вы нас общими словами кормите?
ЦитироватьПроверила, в большинстве случаев поправка верная подставляется, но не всегда.
ЦитироватьИ опять же в большей части вводится верная поправка но иногда и осечка случается
Где примеры того что "сечется"?
кладите четкое объяснение ПОЧЕМУ при таких-то числах должен быть такой-то коэффициент.
Не можете словами - кладите таблицу с четырьмя столбцами
Число1; Число2; Коэф; ПОЧЕМУ такой коэф


Спасибо большое! Вот эта формула подошла идеально
=ИНДЕКС($B$2:$G$6;ПОИСКПОЗ(ОКРУГЛТ(C25-1E-14;2);$A$2:$A$6;0);ПОИСКПОЗ(ОКРУГЛТ(C26-1E-14;5);$B$1:$G$1;0))
раз сто проверяла, осечек не было не раз, но только для положительных показаний. А для отрицательных никак не пошла.
В прикрепленном файле  видно. Таблица  большая, это только часть ее. При снятии показаний необходимо вводить поправку, а так как показания не всегда бывают идеальные как по таблице приходится интерпретировать. Действует такой интервальный принцит. В столбце А 11 для положительных значений ровно середина выбирается как большее значение. Например 3,0 поправка выбираем как за 2,0. А уже 3,1  выбираем как за 4,0. В столбце А11 для отрицательных значений ровно середина -3,0 выбирается как за -4,0. А -2,9 как за -2. Еще раз повторяю для положительных значений ваша формула подошла идеально, помогите пожалуйста с формулой для всего диапазона значений. В прикрепленном файле во второй таблице есть примеры с различными интервальными значениями.Заранее благодарю. ket@ru

_Boroda_

Так. Давайте уже с Вами определимся.
Цитироватьдля положительных значений ровно середина выбирается как большее значение. Например 3,0 поправка выбираем как за 2,0
Большее значение от 3 (3 - это вроде середина между 2 и 4?) будет 4, а не 2, как Вы в следующем же предложении пишете.
Что нужно?
И еще
в шапке первого примера был интервал 5. Поэтому работала формула ОКРУГЛТ(C26-1E-14;5).
Сейчас интервал плавающий. Возможно, в следующем Вашем сообщении окажется, что и по столбцу тоже интервал не 2, а непонятно что. Такое впечатление, что Вы заранее не знаете, что у Вас там будет. Может, выложите уже таблицу, какаю будет на самом деле?
В Вашем последнем примере какие должны быть результаты при значениях 8 - 191 и 8 - 192? 1,5 и 1,6 или еще как-то? Если еще как-то, то почему?
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

ket@ru

Цитата: _Boroda_ от 22.07.2011, 22:43
Так. Давайте уже с Вами определимся.
Цитироватьдля положительных значений ровно середина выбирается как большее значение. Например 3,0 поправка выбираем как за 2,0
Больеше значение от 3 (3 - это вроде середина между 2 и 4?) будет 4, а не 2, как Вы в следующем же предложении пишете.
Что нужно?
И еще
в шапке первого примера был интервал 5. Поэтому работала формула ОКРУГЛТ(C26-1E-14;5).
Сейчас интервал плавающий. Возможно, в следующем Вашем сообщении окажется, что и по столбцу тоже интервал не 2, а не понятно что. Такое впечатление, что Вы заранее не знаете, что у Вас там будет. Может, выложите уже таблицу, какаю будет на самом деле?
В Вашем последнем примере какие должны быть результаты при значениях 8 - 191 и 8 - 192? 1,5 и 1,6 или еще как-то? Если еще как-то, то почему?
Таблица, из которой берутся поправки  в прикрепленном файле первая. А вторая как пример. Хотела показать, что  бывают другие значения которые не строго по таблице а попадают в интервал. Берется показания двух приборов, но так как приборы не идеальны необходимо вводить на их показания поправки. Строка -это показания одного прибора столбец другого но данные их работают на один результат  чтобы он был точнее вводится поправка этих двух приборов. Но и показания  же не могут быть идеальные как строго по таблице.  например 2;4;6;-2; 175;180 и т.д. А бываю и 2,1; 3,8; 4,5;177,5; 183,3;  и т.д.   Если в бумажном варианте. То сняли показания приборов, например 2,2;173,3  выбираем в столбце -  2,2 он попал  в интервал между 2 и 4 и и в строке 173,3.  Так как 173,3 в таблице нет его округляем,  получается 175. в таблице на 175 (строка) и  в столбце 2,2(который мы интерпретировали) в пересечении выбираем   поправку 1,5. К показаниям одного прибора 173,3 + 1,5(выбранная поправка )= 174,8 (конечный результат). 
Но здесь же опять свое условие выбора. Для строки мы показания округляем до  кратное 5. Д ля положит значений в столбце. Если снятое значение получилось ровно середина интервала например 1 которая лежит в интервале 0-2  берем поправку большую в этом интервале как  за 0, а если еже 1,1 как положено в математике за 2. В отрицательных значения столбца.  Например -3,0 выбирается в интервальном приделе между -2,0 и-4,0 и выбирается большая как за -4,0. А если -2,9 то выбирается как за -2,0.
-3,0
177,2 +1,8 =179,0
-2,9
177,2+1,7=178,9
В электронном варианте при внесение показаний двух приборов чтобы поправка вводилась автоматически и далее автоматически суммировалась. Насчет суммирования  это просто я сделала, а вот с формулой для автоматического ввода поправки бьюсь  очень долго  и не чего не могу придумать, идеально не получалось. Три, четыре раза правильно на пятый не верно. А у вас с формулой получилось идеально, но только на положительные значения. Нужна одна формула для ввода поправок как на положительные значения так же и на отрицательные значения в столбце.