Excel 2003.Автоматический ввод поправок из одной таблицы в другую

Автор ket@ru, 19.07.2011, 09:51

« назад - далее »

_Boroda_

Да что ж это такое-то! Неужели я такой тупой! Опять ничего не понял! У меня же так самооценка начать падать может!

Ладно. Если Вы говорите, что для положительных формула работает, тогда для отрицательных должно быть так:
Цитировать=ИНДЕКС($B$1:$G$11;ПОИСКПОЗ(ОКРУГЛТ(C18-0,00000000000001;2*ЗНАК(C18));$A$1:$A$11;0);ПОИСКПОЗ(ОКРУГЛТ(C19-0,00000000000001;5);$B$1:$G$1;0))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

ket@ru

Цитата: _Boroda_ от 23.07.2011, 14:04
Да что ж это такое-то! Неужели я такой тупой! Опять ничего не понял! У меня же так самооценка начать падать может!

Ладно. Если Вы говорите, что для положительных формула работает, тогда для отрицательных должно быть так:
Цитировать=ИНДЕКС($B$1:$G$11;ПОИСКПОЗ(ОКРУГЛТ(C18-0,00000000000001;2*ЗНАК(C18));$A$1:$A$11;0);ПОИСКПОЗ(ОКРУГЛТ(C19-0,00000000000001;5);$B$1:$G$1;0))

Да это я наверное не могу толково объяснить. Спасибо подошла формулы для отрицательных значений.Но для положительных она не подходит. =ИНДЕКС($B$7:$G$11;ПОИСКПОЗ(ОКРУГЛТ(C30-0,00000000000001;2);$A$7:$A$11;0);ПОИСКПОЗ(ОКРУГЛТ(C31-0,00000000000001;5);$B$1:$G$1;0))- вот это подходит для положительных.  А как совместить их в одну. Показания в течении суток колеблются от положительных до отрицательных и наоборот. Необходимо одна универсальная формула которая вводится в ячейку поправок и при необходимости производит выбор при отрицательных или положительных значения.

cheshiki1

Держите, проверяйте.
=ЕСЛИ(ЗНАК(C18)=-1;ИНДЕКС($B$1:$G$11;ПОИСКПОЗ(ОКРУГЛТ(C18-0,00000000000001;2*ЗНАК(C18));$A$1:$A$11;0);ПОИСКПОЗ(ОКРУГЛТ(C19-0,00000000000001;5);$B$1:$G$1;0));ИНДЕКС($B$2:$G$6;ПОИСКПОЗ(ОКРУГЛТ(C25-0,00000000000001;2);$A$2:$A$6;0);ПОИСКПОЗ(ОКРУГЛТ(C26-0,00000000000001;5);$B$1:$G$1;0)))

_Boroda_

ЦитироватьНо для положительных она не подходит
А объясните мне пожалуйста, почему формула
=ИНДЕКС($B$1:$G$11;ПОИСКПОЗ(ОКРУГЛТ(C30-0,00000000000001;2*ЗНАК(C30));$A$1:$A$11;0);ПОИСКПОЗ(ОКРУГЛТ(C31-0,00000000000001;5);$B$1:$G$1;0))
не подходит для положительных?
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

ket@ru

Цитата: _Boroda_ от 24.07.2011, 14:35
ЦитироватьНо для положительных она не подходит
А объясните мне пожалуйста, почему формула
=ИНДЕКС($B$1:$G$11;ПОИСКПОЗ(ОКРУГЛТ(C30-0,00000000000001;2*ЗНАК(C30));$A$1:$A$11;0);ПОИСКПОЗ(ОКРУГЛТ(C31-0,00000000000001;5);$B$1:$G$1;0))
не подходит для положительных?

Подходит Подходит. Это я напутала, ввела еще ячейки а массив не добавила. Спасибо Большое!!!!

ket@ru

Цитата: cheshiki1 от 24.07.2011, 12:36
Держите, проверяйте.
=ЕСЛИ(ЗНАК(C18)=-1;ИНДЕКС($B$1:$G$11;ПОИСКПОЗ(ОКРУГЛТ(C18-0,00000000000001;2*ЗНАК(C18));$A$1:$A$11;0);ПОИСКПОЗ(ОКРУГЛТ(C19-0,00000000000001;5);$B$1:$G$1;0));ИНДЕКС($B$2:$G$6;ПОИСКПОЗ(ОКРУГЛТ(C25-0,00000000000001;2);$A$2:$A$6;0);ПОИСКПОЗ(ОКРУГЛТ(C26-0,00000000000001;5);$B$1:$G$1;0)))
Ваша формула тоже подошла. Спасибо! Только вот большая. Результат одинаков, буду пользоваться формулой Boroda.