Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

ячейка ссылается на другой файл и выдает нзнач

Автор missttv, 26.07.2011, 16:28

« назад - далее »

missttv

Добрый всем день!
понимаю, что где-то туплю, но не пойму где. подскажите варианты решения такой проблемы, есть два файла "А" и "Б". файл "А" у меня сводный и делает расчеты беря инфу из файла "Б" (в котором два листа Лист1 и Лист2).
Фармула в файле "А" у меня выглядит где-то так (к примеру)

=СЧЁТЕСЛИ('C:\Documents and Settings\My Documents\[Б.xls]Лист1'!$H$16:$H$1500;B11)+СЧЁТЕСЛИ('C:\Documents and Settings\My Documents\[Б.xls]Лист2'!$I$16:$I$1500;B11)

при этом если файлик "Б" у меня открыт, то в файле "А" у меня показывает правильное решение, однако если файл "Б" закрыт, то в файле "А" выдается ошибка #ЗНАЧ.
в чем может быть проблема?

Заранее мерси!  :)

_Boroda_

СЧЁТЕСЛИ с закрытыми файлами работать не хочет
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

missttv


_Boroda_

#3
1) Можно положить сюда файлы
2) Можно попытаться использовать сводную
3) Можно на скрытый лист файла А в Н16 написать
='C:\Documents and Settings\My Documents\[Б.xls]Лист1'!H16
размножить вниз на 1500 строк и СУММЕСЛИ считать по этому скрытому листу
4) Можно нарисовать макрос
5) ...Еще куча всяких можно,
но в любом случае см. п.1
еще
=СУММПРОИЗВ(--('C:\Documents and Settings\My Documents\[Б.xls]Лист1'!$H$16:$I$1500=B11))

Кстати, для СЧЁТЕСЛИ можно писать сразу несколько столбцов
Лист1'!$H$16:$I$1500
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

missttv


missttv

#5
вот

_Boroda_

Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

missttv

#7
Цитата: _Boroda_ от 26.07.2011, 17:17
1) Можно положить сюда файлы
2) Можно попытаться использовать сводную
3) Можно на скрытый лист файла А в Н16 написать
='C:\Documents and Settings\My Documents\[Б.xls]Лист1'!H16
размножить вниз на 1500 строк и СУММЕСЛИ считать по этому скрытому листу
4) Можно нарисовать макрос
5) ...Еще куча всяких можно,
но в любом случае см. п.1
еще
=СУММПРОИЗВ(--('C:\Documents and Settings\My Documents\[Б.xls]Лист1'!$H$16:$I$1500=B11))

Кстати, для СЧЁТЕСЛИ можно писать сразу несколько столбцов
Лист1'!$H$16:$I$1500

просто сводними пользоваться не умею, скрытый лист тоже не выход, т.к. файлов несколько и они на разных диска (так нужно), с макросами не дружу. На несколько столбцов тоде не получится т.к. столбец Н на Листе1, а стоббец І на Листе2.
по СУММПРОИЗВ чего-то не получилось. значения выдает тысячные и не хочет суммировать второй лист.

_Boroda_

про разные листы я не заметил
тогда
=СУММПРОИЗВ(--('C:\Documents and Settings\My Documents\[Б.xls]Лист1'!$H$16:$H$1500=B11))+СУММПРОИЗВ(--('C:\Documents and Settings\My Documents\[Б.xls]Лист2'!$I$16:$I$1500=B11))

А что значит "значения выдает тысячные"?
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

missttv

Цитата: _Boroda_ от 27.07.2011, 13:16
про разные листы я не заметил
тогда
=СУММПРОИЗВ(--('C:\Documents and Settings\My Documents\[Б.xls]Лист1'!$H$16:$H$1500=B11))+СУММПРОИЗВ(--('C:\Documents and Settings\My Documents\[Б.xls]Лист2'!$I$16:$I$1500=B11))

А что значит "значения выдает тысячные"?

я как раз так сразу после вашего сообщения и сделала (чуть выше выложила файлики), только чего-то у меня не получился правильный ответ вместо 3 или 4 у меня 2972  :'(

_Boroda_

А все потому, что скобка не там стоит
=СУММПРОИЗВ(--('C:\Documents and Settings\My Documents\[Б.xls]Лист1'!$H$16:$H$1500=B11))+СУММПРОИЗВ(--('C:\Documents and Settings\My Documents\[Б.xls]Лист2'!$I$16:$I$1500=B11))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

missttv

О!!!  ::) заработало!!! спасибочки! дай Бог вам здоровьичка!