Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Проблемка с ссылкой

Автор viter, 07.08.2011, 23:13

« назад - далее »

viter

Помогите, пожалуйста, найти решение проблемки. Есть - компании (диапазон F3:K3) и цены (диапазон F6:K6).
Необходимо в ячейке C6  подставить наименьшую цену из диапазона , а в ячейку D6 - название компании предлагающая наименьшую цену.
Спасибо!

Serge 007

формула массива (вводится Ctrl+Shift+Enter):
=ИНДЕКС(F3:J3;;МАКС(ЕСЛИ(F6:J6=МИН(F6:J6);СТОЛБЕЦ(A1:E1))))

Но это если все цены уникальны. А если несколько компаний предложат одинаковую минимальную цену?
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

cheshiki1

или так
=ИНДЕКС($F$3:$K$6;1;ПОИСКПОЗ($C$6;$F$6:$K$6;0))