Вычисление суммы чисел не превышающей заданное значениие

Автор silentland, 12.08.2011, 21:06

« назад - далее »

silentland

Из первых нескольких чисел, сумма которых меньше контрольного числа, нужно сложить те, напротив которых стоит «X». Результат поместить в какую-нибудь ячейку.
Т.е. в примере это будут числа 12,3,7, т.к. их сумма (24) меньше контрольного числа (26), но из них сложатся только 3 и 7, помеченные «X»,т.е. ответ будет 10.



И это нужно сделать без VB, циклических ссылок и дополнительных ячеек. Такое, вообще, возможно?

MCH


silentland

Цитата: MCH от 12.08.2011, 22:33
как то так

С доп. столбцом я тоже делал. А одной формулой уже интереснее, правда, почему-то ответы не сходятся :-)

MCH

Цитироватьпочему-то ответы не сходятся :-)
У меня все сходится

silentland

Цитата: MCH от 12.08.2011, 22:49
Цитироватьпочему-то ответы не сходятся :-)
У меня все сходится
Да, сходится, это мой косяк, когда выделили ячейку в ней почему-то пропали фигурные скобки. Зачем они, вообще, нужны?

IKor

Цитата: silentland от 12.08.2011, 23:10
Да, сходится, это мой косяк, когда выделили ячейку в ней почему-то пропали фигурные скобки. Зачем они, вообще, нужны?
Фигурные скобки - это признак введенной формулы массива - для ее ввода выполняются следующие действия:
- по обычным правилам в ячейку записывается формула;
- выделяется требуемый диапазон ячеек, так, чтобы ячейка с формулой оказалась в его левом верхнем углу (дипазон размером 1х1 ячейку - частный случай);
- переходим в режим редактирование формул (ЛКМ по строке редактирования или F2)
- вместо ENTER нажимает CTRL+SHFT+ENTER

silentland

Что-то совсем не могу понять как работает формула:

{=СУММ((ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(A2;;;СТРОКА(A2:A9)-СТРОКА(A1)))<G1)*A2:A9*(B2:B9="X"))}

Особенно: СТРОКА(A2:A9)-СТРОКА(A1), которая без контекста всегда дает 1
Так же непонятно, зачем: *A2:A9*

Serge 007

Цитата: silentland от 13.08.2011, 10:44
СТРОКА(A2:A9)-СТРОКА(A1), которая без контекста всегда дает 1
Неверно.
Эта часть формулы возвращает массив {1;2;3;4;5;6;7;8}.
Только вчера объяснял подобное здесь.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

silentland