Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Ссылка на текущую ячейку в Диспетчере имен

Автор silentland, 14.08.2011, 22:45

« назад - далее »

silentland

Заношу массивы в диспетчер имен. Нужно добавить диапазон от А5 до Аn, где Аn — адрес ячейки в которой находится формула.
='Лист 1'!$А$5:$Аn

Пробовал
='Лист 1'!$А$5:$А5
но как-то это через раз работает.

Как сделать?

cheshiki1


silentland

Даже не знаю, что должно быть в примерчике...

Кое-что изобразил.

silentland

#3
Решил проблему. Записал в диспетчер имен формулу:

=ДВССЫЛ("'Лист 1'!$F$5"&":"&ТЕКСТ(АДРЕС(СТРОКА();6);""))

которая возвращает ссылку: ='Лист 1'!$F$5:$Fn

Правда, решение не кажется мне оптимальным. Может быть есть способ лучше?

Serge 007

Цитата: silentland от 15.08.2011, 02:28
Может быть есть способ лучше?
Лучше - нет.
Есть альтернатива: =СМЕЩ('Лист 1'!$F$5;;;СЧЁТЗ('Лист 1'!$F$5:'Лист 1'!$F$1000))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

silentland

Кстати, в моем примере используются ссылки на одну ячейку, записанные в диспетчере как

='Лист 1'!$F5 (на деле вместо 5 подставляется индекс ячейки с формулой) и все прекрасно работает. Почему же тупит ='Лист 1'!$F$5:$F5 ума не приложу.

cheshiki1

ну наверно потому что когда Вы вводите допустим ДебетТек в другой ячейке автоматически меняется диаппазон имени т.е. он состоит уже не из одного значения. И зачем Вам диаппазон если Вы ссылаетесь на одну ячейку.

silentland

Цитата: cheshiki1 от 15.08.2011, 11:48
И зачем Вам диаппазон если Вы ссылаетесь на одну ячейку.

Просто эта ячейка на другом листе. Чтобы название листа не писать.

Serge 007

Цитата: silentland от 15.08.2011, 17:06
Просто эта ячейка на другом листе. Чтобы название листа не писать.
Если диапазон или ячейка на другом листе - то необходимо имя.
Excel не поддерживает адресацию на другой лист в именах.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

silentland

Цитата: Serge 007 от 15.08.2011, 17:13
Excel не поддерживает адресацию на другой лист в именах.
:o

Тогда мой пример не должен работать. Или я как не так понял?

Serge 007

Цитата: silentland от 15.08.2011, 17:36
Цитата: Serge 007 от 15.08.2011, 17:13
Excel не поддерживает адресацию на другой лист в именах.
Тогда мой пример не должен работать. Или я как не так понял?
У Вас адресация в именах?
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

silentland

#11
Цитата: Serge 007 от 15.08.2011, 17:44
Цитата: silentland от 15.08.2011, 17:36
Цитата: Serge 007 от 15.08.2011, 17:13
Excel не поддерживает адресацию на другой лист в именах.
Тогда мой пример не должен работать. Или я как не так понял?
У Вас адресация в именах?

Т.е.? Видимо я не догоняю, что значит адресация в именах. Имя выглядит как адрес?


Еще есть вопрос, но немного не по теме: в функции

=СУММЕСЛИМН(B2:B12;A2:A12;-СЕГОДНЯ()&"<30")

почему-то никогда не выполняется условие.

{=СУММ(B2:B12*(A2:A12-СЕГОДНЯ()<30))} работает как надо, но она функция-массива

Пример вложил.