как брать данные из второго файла

Автор jundik, 30.08.2011, 18:55

« назад - далее »

jundik

добрый день. прошу помощи, так как сам в экселе не силен. ситуация такая: в логистической фирме ведется учет заказов в файл vopros.xls. нужно осуществить следующее: при заполнение определенных ячеек в строке (страна получения, тип отправления, количество и вес) в ячейке тарифы должна появляться цена, которая берется из файла tablica.xls (в которой страны разбиты на регионы). как я понимаю, без макроса тут не обойтись?
Office 2003 eng.
очень рассчитываю на вашу помощь. спасибо.

sergo44441

Может быть и макросом, вы только опишите методику подстановки данных на примере
Не торопись, и все успеешь намного быстрее

jundik

Цитата: sergo44441 от 31.08.2011, 04:55
Может быть и макросом, вы только опишите методику подстановки данных на примере

ну в файле "вопрос" заполняется строка. из этой строки только 4 ячейки и формируют конечную цену. при заполнении их в ячейке "тарифы" должна появиться эта самая цена, которая бы бралась с файла "таблица"

например:

Страна получения / Вес / Кол-во мест / Тип отправления / цена
China                      0,2           1              PLX                   ? (данные берутся из прейскуранта другого файла)

jundik


nilem

Если все сложить в один файл, немного изменить таблицу с тарифами, убрать пробелы в названиях стран и пустые строки на листе cantries, а также использовать именованные диапазоны, то буквально одной простой формулой:
=ВПР(K2*L2;ДВССЫЛ(N2);ВПР(J2;countries!$B$2:$C$213;2;0)+2)
Но это, конечно, если правильно понял. Проверьте.