Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Нахождение одинаковых знаков

Автор Anita, 14.09.2011, 11:20

« назад - далее »

Anita

Например:
+
+
+
-
-
+
Здесь 3 серии, т.е. 1 серия это три знака +, 2 серия это 2 знака -, и 3 серия это один +....как это посчитать в Excel?

_Boroda_

Такие два варианта
для постоянного диапазона и для произвольной высоты
=СУММПРОИЗВ(--(A1:A13<>A2:A14))
=СУММПРОИЗВ(--(СМЕЩ(A1;;;СЧЁТЗ(A:A)-1)<>СМЕЩ(A1;1;;СЧЁТЗ(A:A)-1)))
см. вложение
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Anita

Спасибо большое Вам за помощь.
Осталось только разобраться как это действует.
...Если не затруднит, у меня есть еще один вопрос связанный все с этими же сериями: надо найти протяженность самой длинной серии.

Михаил С.

#3
Проверьте
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

Anita

Спасибо. Проверила. Формула для динамического диапазона работает, а другая нет: она почему считает длину только первой серии и выдает это число как ответ.

Михаил С.

Цитата: Anita от 15.09.2011, 18:17а другая нет: она почему считает длину только первой серии и выдает это число как ответ.
Проверьте еще раз, у меня считает одинаково.
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

Anita

Да.извините.ошиблась.
Никак не могу формулу для постоянного диапазона перенести на свой пример.
Если не сложно посмотрите (ячейку я выделила красным цветом).

Михаил С.

Исправьте в формуле ВСЕ E1:E36 на E1:E37; E2:E37 на E2:E38
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

Anita