Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Номер квартала по дате

Автор pav18, 29.09.2011, 19:03

« назад - далее »

pav18

Помогите пожалуйста составить формулу для Excel 2003
Суть в том что имеется столбец в который вводятся даты в течении года и есть 4 не календарных отчетных квартала ограниченных датами.
Необходима формула которая бы определяла к какому из 4-х отчетных кварталов относится эта дата и в соседней ячейке прописывала бы название этого отчетно квартала, например "1 Квартал".
Периоды ограничены:
1 Квартал 05.01.11 - 04.04.11
2 Квартал 05.04.11 - 04.07.11
3 Квартал 05.07.11 - 04.10.11
4 Квартал 05.10.11 - 04.01.12
:(

Serge 007

=ПОИСКПОЗ(B10;$B$3:$B$6)
или без доп таблицы (но только на этот год):
=ПОИСКПОЗ(B10;{40548;40638;40729;40821})
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

MCH

=ЦЕЛОЕ((МЕСЯЦ(B10-4)+2)/3)&" Квартал"

zs

Замок IF надежней =ЕСЛИ(((МЕСЯЦ(F2))/4)<1;1;ЕСЛИ(((МЕСЯЦ(F2))/4)<1,6;2;ЕСЛИ(((МЕСЯЦ(F2))/4)<2,26;3;ЕСЛИ(((МЕСЯЦ(F2))/4)<3,1;4;0))))

Wasilic

Или так!
=ЕСЛИ(И(B10>=$B$3;B10<=$C$3);1;ЕСЛИ(И(B10>=$B$4;B10<=$C$4);2;ЕСЛИ(И(B10>=$B$5;B10<=$C$5);3;ЕСЛИ(И(B10>=$B$6;B10<=$C$6);4;"")))) & " квартал"
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.