Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Выбор значения из строки

Автор SEVERO, 17.10.2011, 14:15

« назад - далее »

SEVERO

Доброго времени суток, столкнулся со следующей ситуацией: необходимо из строки выбрать значение либо золото, либо серебро, либо платина, если вышеуказанных значений нет, то тогда должно отображаться слово обычный.

Пример прилагаю.

уже неделю пытаюсь решить ситуацию - мозг закипел :'(, буду признателен sm_bow за помощь.

заранее благодарю за советы

exceleved

Так по-простому:=ЕСЛИ(СЧЁТЕСЛИ(A2:I2;"серебро");"серебро";
ЕСЛИ(СЧЁТЕСЛИ(A2:I2;"золото");"золото";
ЕСЛИ(СЧЁТЕСЛИ(A2:I2;"платина");"платина";"обычный")))

_Boroda_

Или
=ЕСЛИОШИБКА(ИНДЕКС(A2:I2;СУММПРОИЗВ((A2:I2<>"Обычный")*СТОЛБЕЦ(A2:I2)));"Обычный")
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

SEVERO