Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Про разряды в числах

Автор Ananas, 28.10.2011, 12:23

« назад - далее »

Ananas

Из 100000.00 нужно получить 100,000.00


То есть воткнуть эту запятую.
Пробовала все варианты в формате ячейки - получается только пробел на месте запятой, а надо всенепременно с запятой.

Мой способ противный и наверное неправильный, может проще можно.

Я делаю загадочную функцию dollar().
Получается 100 000.00р. (то есть показывается с пробелом).
Дальше копирую это как значение, реплейсом меняю пробел на запятую и убираю "р.".
Но если среди прочих попалось число меньше 1000 и без знаков после точки, после этих реплейсов пропадают ".00"

А хочется одной функцией.

_Boroda_

Попробуйте
=ТЕКСТ(A2;"#"&СИМВОЛ(34)&","&СИМВОЛ(34)&"##0,00")
На русской версии работает

На англ думаю, что будет так:
=ТЕКСТ(A2;"#"&СИМВОЛ(34)&","&СИМВОЛ(34)&"##0.00")
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

MCH

Если стандартный разделитель целой и дробной части - запятая, то:
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(ТЕКСТ(A2;"# ##0,00");",";".");" ";",")

если точка:
=ПОДСТАВИТЬ(ТЕКСТ(A2;"# ##0.00");" ";",")

iron priest

это меняется в настройках языка и рег. стандартах компа, где указывается разделитель групп разрядов и делитель целой и дробной части

Ananas

Цитата: iron priest от 28.10.2011, 16:56
это меняется в настройках языка и рег. стандартах компа, где указывается разделитель групп разрядов и делитель целой и дробной части
Да знаю я, знаю! В 99.9% случаев мне нужны настройки "Россия".
Но вот есть одна штука, где надо в американском (или чей это?) формате.


_Boroda_, попробовала. При трехзначных числах не подходит - впереди болтается запятая.
МСН - вот этот вариант отличный, спасибо!