Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Простая сложная формула на основе ЕСЛИ-СЦЕПИТЬ. Прошу помощи!

Автор Che79, 29.10.2011, 21:42

« назад - далее »

Che79

Уважаемые знатоки!))
Вот такая простая-сложная задача. Пример и описание прилагаются.  Подозреваю , что в разных версиях Excel она может решаться по-разному...Я что-то подвис..
Прошу вашей помощи в решении.

С уважением к форуму
Делай нормально и будет нормально!

Serge 007

формула массива (вводится нажатием Ctrl+Shift+Enter) для всех версий Excel:
=ИНДЕКС(B2:M2;;МИН(ЕСЛИ(ЕЧИСЛО(B3:M3);СТОЛБЕЦ(A1:L1))))&" "&ИНДЕКС(B2:M2;;МАКС(ЕСЛИ(ЕЧИСЛО(B3:M3);СТОЛБЕЦ(A1:L1))))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Che79

Вот как, однако! Спасибо!
Единственное, сейчас в случае, если заполнен один месяц, например август, то в ячейке выводится "август август" и без так необходимого дефиса...
Делай нормально и будет нормально!

MCH

формула массива:
=ИНДЕКС(B2:M2;ПОИСКПОЗ(ИСТИНА;B3:M3<>"";))&"-"&ПРОСМОТР(2;1/(B3:M3<>"");B2:M2)

Serge 007

Цитата: Che79 от 29.10.2011, 22:20...в случае, если заполнен один месяц, например август, то в ячейке выводится "август август" и без так необходимого дефиса...
Да, заметил уже и исправил.
См. вложение.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Che79

Делай нормально и будет нормально!

MCH

или так:
=ЕСЛИ(СЧЁТ(B3:M3)>1;ИНДЕКС(B2:M2;ПОИСКПОЗ(ИСТИНА;B3:M3<>"";))&"-";"")&ПРОСМОТР(9E+307;B3:M3;B2:M2)