Получение среднего балла

Автор RainbowEyes, 01.11.2011, 18:54

« назад - далее »

RainbowEyes

Здравствуйте. Возникла необходимость в такой вещи.
Есть некая ячейка. Внутри неё записаны оценки ученика, подряд, без разделителей: 5455234
Как из этих чисел, находящихся в одной (это важно!) ячейке, получить средний балл ученика?
Я понимаю, что все числа нужно сложить между собой и поделить на их количество. Но как их между собой сложить-то?

kuklp

Я, как всегда, чертовски адекватен... Email: pilipnikop@yandex.ua WM Z206653985942, R334086032478, U238399322728, E332314026771


DV68

Среднее значение:
=СУММПРОИЗВ(ПСТР(A1;СТРОКА($A$1:ИНДЕКС($A:$A;ДЛСТР(A1)));1)/ДЛСТР(A1))

MCH

#4
еще вариант:
=СУММПРОИЗВ((0&ПСТР(A1;СТРОКА($1:$10);1))/ДЛСТР(A1))
Хотя вариант Dmitr68 более универсальный

баз текстовых фунций:
=СУММПРОИЗВ(ОСТАТ(ЦЕЛОЕ(A1/10^(СТРОКА($1:$10)-1));10))/ЦЕЛОЕ(LOG(A1)+1)