Вычесление интервалов по данным из нескольких столбцов. Нужна помощ

Автор SlaFFkaQC, 09.11.2011, 16:35

« назад - далее »

SlaFFkaQC

Проблема заключается в следующем:
имеется две таблицы с числовыми данными. в первой описаны номера линий и интервалы на них в таком формате - номер линии (50960), от номера точки (2216), до номера точки (2300). Длинна интервалов периодически меняется. Пример ниже.
50960   2216   2300
51040   2216   2300
51120   2216   2300
51200   2216   2300
51280   2216   2300
51360   2216   2300
51440   2216   2300
51520   2216   2300
Во второй таблице описываются интервалы, число точек в которых и надо автоматически вычислить при нескольких условиях - интервал во второй таблице должен быль в границах интервалов, указанных в первой таблице, номера линий должны совпадать. Кроме того, во второй таблице интервалов может быть несколько. Ниже пример ожидаемого результата:
Таблица 1
50960   2216   2300
51040   2216   2300
51120   2216   2300
51200   2216   2300
Таблица 2
51040   2254   2254
51120   2257   2258
51200   2441   2441
51200   2491   2491
Желаемый результат:
50960   2216   2300        0
51040   2216   2300        1
51120   2216   2300        2
51200   2216   2300        0

Если кто нибудь поможет дельным советом буду очень благодарен до глубины души.
Заранее спасибо.

exceleved


SlaFFkaQC

Немножко не верно. В первой же строке вычисления показали одну точку пропуска (на линии 50960), а как видно из таблицы пропусков их 4. Но все равно спасибо, появилось новое направление для размышлений.

SlaFFkaQC

Вот, придумал формулку, но она не хочет считать выражения больше-меньше. Считает только тогда, когда подставляешь числа, а мне нужно подставлять ячейки.  Помогите её добить...
=СУММЕСЛИМН($N$3:$N$16;$K$3:$K$16;D2;$L$3:$L$16;">=2216";$M$3:$M$16;"<=2300") в таком формате считает без проблем
=СУММЕСЛИМН($N$3:$N$16;$K$3:$K$16;D2;$L$3:$L$16;">=E2";$M$3:$M$16;"<=F2") а вот так не считает. а мне нужно именно так...

Serge 007

Так что ли?

=СУММПРОИЗВ(($K$3:$K$16=D2)*($L$3:$L$16>=E2)*($M$3:$M$16<=F2)*$N$3:$N$16)

Или так можно:
=СУММЕСЛИМН($N$3:$N$16;$K$3:$K$16;D2;$L$3:$L$16;">="&E2;$M$3:$M$16;"<="&F2)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

SlaFFkaQC

Супер, считает!!! Спасибо!!! Но теперь столкнулся с другой проблемой - допустим я анализирую линию 50960 с точки 2216 по точку 2300, при этом есть пропуск на этой же линии с точки 2298 по точку 2304. В таком случае интервал пропусков будет 2298-2300 (то есть три точки). А данная формула такой вариант отвергает по причине невыполнения условия "<="&F2. Или на оборот - пропуск на точках 2212 по 2220. Тогда сумируются пропуски 2216-2220.
Пример во вложении.

ShAM


SlaFFkaQC

Тоже вариант, только при изменении интервалов анализа, количество пропусков не меняется. Так что не подходит.
Что получилось в итоге - в приложении.

Serge 007

Цитата: SlaFFkaQC от 10.11.2011, 13:41
Что получилось в итоге - в приложении.
Почему в О10 (Номер линии 51280) формула ссылается на Е9 и F9 (Номер линии 51520)?
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

ShAM

Цитата: Serge 007 от 10.11.2011, 14:33
Цитата: SlaFFkaQC от 10.11.2011, 13:41
Что получилось в итоге - в приложении.
Почему в О10 (Номер линии 51280) формула ссылается на Е9 и F9 (Номер линии 51520)?
Это осталось с первоначального варианта, где в столбцах E, F были одинаковые значения. Поздно увидел, что ссылается не туда, но значения были одинаковые и на расчеты не влияло. Т.е. в формулы вместо Е2-Е15 можно было поставить 2216, вместо F2-F15 поставить 2300.
Хотелка все усложняется, и не совсем понятно, что должно получиться в оконцовке, как должно быть правильно?

SlaFFkaQC

Обрисую более полную картину задачи.
У меня есть таблица, в которой описываются отрезки прямых линий. Длинна линий периодически меняется от 72 до 144 единиц.
Есть вторая таблица, в которую вносятся отдельные точки, или группы точек, которые надо исключить из анализа.
Задача в следующем, если на каждую задачу я имею по 8 линий, на которых расположено от 72 до 144 точек, которые в итоге мне нужно проанализировать, как мне вычислить точное число точек, которые исключаются из анализа для каждой операции в отдельности.
Допустим, что если взять отрезок на линии 50975 от точки 2216 до точки 2300, сколько именно пропусков попадет в этот интервал. К примеру я имею пропуски на этой линии от точки 2214 до 2218, от 2248 до 2251, и от 2299 до 2306. Таким образом в зананом интервале (2216-2300) я имею 9 пропусков (2216-2218, 2248-2251, 2299-2300)
Для примера во вложении добавил один из 427 файлов, которые мне надо проанализировать.