Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Переадресация с разных ячеек

Автор MilanAC, 24.11.2011, 11:42

« назад - далее »

iron priest

#15
=ЕСЛИОШИБКА(ИНДЕКС(База!$D$1:$D$5000;НАИМЕНЬШИЙ(ЕСЛИ($F3=База!$C$1:$C$5000;СТРОКА(База!$D$1:$D$5000);"");СТОЛБЕЦ()-1));"")

и избавьтесь от вспомогательных данных. для даты установите формат ячейки ДД.ММ.ГГ", " дддд

MilanAC

Цитата: iron priest от 29.11.2011, 17:35
=ЕСЛИОШИБКА(ИНДЕКС(База!$D$1:$D$5000;НАИМЕНЬШИЙ(ЕСЛИ($F3=База!$C$1:$C$5000;СТРОКА(База!$D$1:$D$5000);"");СТОЛБЕЦ()-1));"")

и избавьтесь от вспомогательных данных. для даты установите формат ячейки ДД.ММ.ГГ", " дддд
Спасибо, век живи век учись.

Но чувствую перемудрил я с этими ячейками.
При изменении данных в листе База компьютер подвисает на 5 секунд (При условии обработки из графика работ по 5000 строк)
При изменении данных в листе База компьютер подвисает на 2 секунды (При условии обработки из графика работ по 1000 строк).
Т.е. получается, что при работе с большим количеством строк эта формула неэффективна.
* Буду ломать голову. А в Excel существует реляционный тип связи данных как в Access? Я допустим в столбец привязываю календарь через VBA, а затем этот столбец связывается со столбцом из ГрафикаПродаж. Или это опять же получится шило на мыло? Есть смысл копать в этом направлении?

Календарь прикрепил к столбцу.

iron priest

с ассесом не приходилось работать

чтобы комп не подвисал, рекомендуется отключить автовычисление

MilanAC

Спасибо, проблема решилась.

MilanAC

Добрый день, еще вопрос. В эксель есть возможность формирования определенных условий при которых значение в другой ячейки меняется?
Для примера выложил условие, то значение не меняется, а выдается ошибка (позволил себе небольших 2 скрина :P):


Serge 007

Цитата: MilanAC от 02.12.2011, 09:59
В эксель есть возможность формирования определенных условий при которых значение в другой ячейки меняется?
Макросом можно.
Формулы возвращают результат только в ту ячейку где они находятся.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

MilanAC


_Boroda_

Не совсем
Цитироватьзначение в другой ячейки меняется
, но, может, и так нормально будет?
В В2 повводите цифры разные. Правила в В4:С6. От значений в этих ячейках ничего не зависит, это просто объяснялка.
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

MilanAC

Цитата: _Boroda_ от 02.12.2011, 16:03
Не совсем
Цитироватьзначение в другой ячейки меняется
, но, может, и так нормально будет?
В В2 повводите цифры разные. Правила в В4:С6. От значений в этих ячейках ничего не зависит, это просто объяснялка.
Интересное решение, только я не понял, как вы это сделали, формул нет, в VBA пусто :)


И еще в продолжение вопроса О ГрафикеПродаж. Что если Дата продажи допустим 07.01.2012, но мне необходимо занять не одну ячейку в графике продаж, а 3. Допустим, это обусловлено тем, что расстояние до клиента большое и соответственно машина будет задействована для данного заказа на эти 3 дня.
Создана колонка в Базе Количество дней доставки (по умолчанию туда ничего не пишем и соотвественно заказ занимает всего 1 ячейку - как это было предложено  iron priest'ом. Так вот если я вписываю в эту колонку значение "3" дня, то к значению Дата Продаж прибавляется 3 дня и потом это отражается в ГрафикПродаж.
Прикрепил файл и салатовым фоном выделил строку в Базе и ячейки из листа ГрафикеПродаж, которые должны автоматически отображаться :o

_Boroda_

ЦитироватьИнтересное решение, только я не понял, как вы это сделали, формул нет, в VBA пусто
см. условное_форматирование
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995