Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Заполнение ячеек с вариацией

Автор smarty, 26.11.2011, 17:08

« назад - далее »

smarty

Есть, скажем, столбец из 20 ячеек с начальным и конечным значениями (к примеру A1=100, A20=700) Нужно автоматически заполнить остальные  с вариацией, ну скажем ±1,5 вокруг среднего значения (A20-A1)/19. Как сделать? Чуствую можно, но интеллекта не хватает самому разобраться. :-\
TIA

DV68

Выделяем А2:А19
В строке формул пишем:
=СЛУЧМЕЖДУ(((A$20-A$1)/19-1,5)*100;((A$20-A$1)/19+1,5)*100)/100
нажимаем Ctrl+Enter

smarty

#2
Цитата: Dmitr68 от 26.11.2011, 17:37
Выделяем А2:А19
В строке формул пишем:
=СЛУЧМЕЖДУ(((A$20-A$1)/19-1,5)*100;((A$20-A$1)/19+1,5)*100)/100
нажимаем Ctrl+Enter
Спаибо. Не совсем то - но за основу взял.
Мне нужно было вот это
A2=A1+ROUND(RANDBETWEEN(((A20-A1)/19-1,5)*100;((A20-A1)/19+1,5)*100)/100;1)
A3=A2+ROUND(RANDBETWEEN(((A20-A1)/19-1,5)*100;((A20-A1)/19+1,5)*100)/100;1)
A3=A2+ROUND(RANDBETWEEN(((A20-A1)/19-1,5)*100;((A20-A1)/19+1,5)*100)/100;1)
A4=A3+ROUND(RANDBETWEEN(((A20-A1)/19-1,5)*100;((A20-A1)/19+1,5)*100)/100;1)
.
.
.
A19=A18+ROUND(RANDBETWEEN(((A20-A1)/19-1,5)*100;((A20-A1)/19+1,5)*100)/100;1)
Спасибо.

exceleved

Для А2 и протянуть=ОКРУГЛ(A1+(A$20-A$1)/19+(СЛЧИС()-0,5)*3;1)

=ROUND(A1+(A$20-A$1)/19+(RAND()-0.5)*3,1)