Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Поиск количество какойто буквы в тексте

Автор c_zurab, 28.11.2011, 10:14

« назад - далее »

c_zurab

сталкнулся с такой ситуацией.
есть набор букв в ячейке:
WLWDLWWDWWWLWLDDWLDDWDDLDLDDWDWWDLDLDL

надо определить сколько в данном ячейке буквы "D"

подскажите пожалуста какую функцию подставить
Заранее сапасибо

_Boroda_

#1
=ДЛСТР(B5)-ДЛСТР(ПОДСТАВИТЬ(B5;"D";""))

или поизвращаться
=СУММПРОИЗВ(--(ПСТР(B5;СТРОКА(ДВССЫЛ("A1:A"&ДЛСТР(B5)));1)="D"))

Текст находится в ячейке B5
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

c_zurab