Критерий отбора по нескольким значениям в рамках одного условия

Автор STEROID, 28.11.2011, 12:38

« назад - далее »

STEROID

Доброго времени суток!

Имею насущную проблему, перечень наименований окло 40 000 шт в колонке А1 в колонке B2 соответственно

указано количество данного наименования. Цель: подсчитать общее количество заданного наименования

по таблице - ВСЕ ПРОСТО =СУММЕСЛИМН(В1:В40001;А1:А40001;"Шуруп 5*30")

Но есть одно существенное НО, наименования повторяются и вносятся разными исполнителями, отсюда результат

искомое значение "шуруп 5*30" в течении всего диапазона может так же принимать значение "шуруп5*30", "шуруп 5х30",

"шуруп 5*30мм" и тд , соответственно пробовал применить формулу =СУММЕСЛИМН(В1:В40001;А1:А40001;"Шуруп 5*30"

А1:А40001;шуруп5*30";А1:А40001;"шуруп5*30";А1:А40001;"шуруп 5х30";А1:А40001"шуруп 5*30мм"), но в итоге понял

что количество вариаций значения бесконечно, хотя логический смысл одинаков.

До этого искал и вносил все значения вручную Ctrl+F, в поле "НАЙТИ" забивал "шуруп*5*30" (знак * помогал отсеять все лишнее),

в поле "найти все" выдавал все перечисленные выше наименования, после чего сумму полученных считал и вносил вручную.

ВОПРОС: можно ли в критерии отбора забить несколько значений согласно одного поиска, в приведенном примере это будет

"шуруп", "2" и "30" (это базовые параметры, которые следует искать согласно одного поиска, при которых сохранится

логический смысл поиска и будут выбраны все наименования)

Буду безразмерно благодарен за любое предложение или совет!

_Boroda_

Цитата: STEROID от 28.11.2011, 12:38
ВОПРОС: можно ли в критерии отбора забить несколько значений согласно одного поиска, в приведенном примере это будет
"шуруп", "2" и "30"
И где он, пример приведенный?
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

STEROID

Вот краткий пример. так я пользуюсь CTRL+F вручную, а рядом формула которую я хотел применить для автоматизации процесса, но формульно не получается охватить весь диапазон наименований, перечислять тупо все возможные БЕССМЫСЛЕННО, т.к. каждый день меняются исполнители, не исключены новые варианты, я лишь подбиваю итог, для итога мне достаточно только базовые параметры "шуруп", "5" и "30", т.е. они по любому будут фигурировать в значении наименовании.

STEROID

Цитата: _Boroda_ от 28.11.2011, 13:27
Цитата: STEROID от 28.11.2011, 12:38
ВОПРОС: можно ли в критерии отбора забить несколько значений согласно одного поиска, в приведенном примере это будет
"шуруп", "2" и "30"
И где он, пример приведенный?

Пример в смысле:"До этого искал и вносил все значения вручную Ctrl+F, в поле "НАЙТИ" забивал "шуруп*5*30" (знак * помогал отсеять все лишнее),

в поле "найти все" выдавал все перечисленные выше наименования, после чего сумму полученных считал и вносил вручную."

_Boroda_

Выдержка из правил (кстати, почитайте на досуге - много интересного обнаружите)
Цитировать...
2. К первому сообщению темы должен быть прикреплен файл изображения и / или файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.
Прикрепить к сообщению можно только файлы gif,jpg,rar,zip,7z,bas,frm,cls,docx,xlsx,xls размером до 1000 Кб.
Прикрепить файл можно в полной форме ответа на сообщение. Под окном для ввода сообщения нажмите на знак "+" возле текста "Дополнительные опции..."
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

DV68


STEROID

Цитата: Dmitr68 от 28.11.2011, 14:46
=СУММЕСЛИ(A1:A40001;"*шуруп*5*30*";B1:B40001)
Разницы не вижу никакой в сравнении с мой формулой, только разве что в СУММЕСЛИМН можно вносить дополнительные критерии отбора!

_Boroda_

Вот если Вы упрямиться перестанете и наконец-то пример приложите, то мы Вам разницу на нем и покажем.
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

STEROID

Цитата: _Boroda_ от 28.11.2011, 15:10
Вот если Вы упрямиться перестанете и наконец-то пример приложите, то мы Вам разницу на нем и покажем.
Пример выложил! :)
Спасибо за замечание, благодаря ему перечитал предыдущее сообщение, увидел разницу и все заработало!


STEROID

Цитата: STEROID от 28.11.2011, 14:55
Цитата: Dmitr68 от 28.11.2011, 14:46
=СУММЕСЛИ(A1:A40001;"*шуруп*5*30*";B1:B40001)
Разницы не вижу никакой в сравнении с мой формулой, только разве что в СУММЕСЛИМН можно вносить дополнительные критерии отбора!
Прошу прощения, читал невнимательно. пропустил *шуруп*5*30*, все заработало!

Огромное Вам спасибо, сократили мою работу на 30% !

Тему можно считать закрытой!