Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Формула выбора повторяющихся данных

Автор Evgeniykg, 03.12.2011, 11:50

« назад - далее »

Evgeniykg

Необходимо из массива выбрать уникальный текст.
Поясню, в массиве идут данные:
  Первое значение
  Второе значение
  Просто значение
  Первое значение
  Первое значение
  Второе значение


Результат работы формулы:
  Первое значение
  Второе значение
  Просто значение


Остальные ячейки пустые.
Какую формулу можно использовать?

_Boroda_

Вам нужно именно формулой? В Excel 2007/2010 есть кнопочка на вкладке "Данные". Называется "Удаление дубликатов". Если у Вас это операция разовая, то можно использовать эту кнопку.
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Evgeniykg

Цитата: _Boroda_ от 03.12.2011, 12:36
Вам нужно именно формулой? В Excel 2007/2010 есть кнопочка на вкладке "Данные". Называется "Удаление дубликатов". Если у Вас это операция разовая, то можно использовать эту кнопку.

Excel 2010.
До сего моменте пользовался этим способом. Но возникла необходимость динамического обновления вводимых данных.
Я нашел например такую формулу

{=ИНДЕКС(массив;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(массив;массив;0)=СТРОКА(массив)-СТРОКА($A$3);ПОИСКПОЗ(массив;массив;0));СТРОКА(1:1)))}

Где ($A$3) первая ячейка массива.
Но ни как не могу заставить ее работать.
Получается,  что массивы надо вводить особым образом, нажатием клавиш Ctrl+Shift+Enter.
Что не делаю формула не работает
или выдает ошибку
Или отображается как текст
С формулами массивов работаю впервые
Что делать...?

_Boroda_

ЦитироватьЧто делать...?
1. читать правила форума
2. класть сюда файл

"массив" - это именованный диапазон (см. Вставка - Имя). После того, как Вы создадите его - Предположу, что формула должна быть такая =СМЕЩ($A$2;;;СЧЁТЗ(A:A)-1)
у Вас заработает и основная формула
НО!!! На больших объемах будет очень сильно тормозить
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Evgeniykg

Прошу прощения, действительно не читал правил.

Как назначать имена массивам разобрался, спасибо!
Сейчас попробовал опять не работают.
Короче уже начинаю путаться.

Я владею Excel на уровне простых отчетов и смет.
Так что большая просьба объяснять как начинающему.

Файл на котором экспериментирую.

DV68

формула массива вводится одновременным нажатием трех клавиш: Ctrl+Shift+Enter

Evgeniykg

В том то вся и проблема.
Когда надо жать?
Я уже наверное все варианты нажатия перепробовал, все равно не вводиться :-\

_Boroda_

формула написана правильно
выделяете одну ячейку с формулой, встаете в строку формул, жмете сразу контрл шифт ентер
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Evgeniykg

Большое спасибо!!!!!!!!!!
Все получилось.
А такая мелочь... - просто надо знать.
_Boroda_ очень благодарен за проявленное терпение, жаль не вижу где можно поставить + (наверное из-за того что сегодня зарегистрировался).
Давно я не получал таких терпеливых ответов.
С вашего форума уже не уйду!
Еще раз спасибо!

Evgeniykg