Расчет пеней.

Автор slavabatov, 14.12.2011, 15:49

« назад - далее »

slavabatov

Добрый день.
Подскажите, пожалуйста, как можно рассчитать размер пени если % изменяется в зависимости от количества дней просрочки.
Т.е. количество дней просрочки я считаю в отдельном столбце (например 120 дней), а затем имеются условия, 45 дней без пени, с 46-го по 60-ый 12 % от стоимости (например 100 руб), с 61-го по 90-й 24 %, более 90 дней 30 %.
Значит за 15 дней 1,8 руб + за 30 дней 7,2 руб + и ещё 30 дней 9 руб    Итого пени за 75 дней сверх срока составляет 18 руб

slavabatov


Wasilic

Цитата: slavabatov от 14.12.2011, 15:49
с 46-го по 60-ый 12 % от стоимости (например 100 руб),
Значит за 15 дней 1,8 руб
Чёй-то я с процентами не врубаюсь. :-\
12% от 100  х 15 = 1,8
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

_Boroda_

У меня вот так получилось. Проверяйте.
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Jim

=ЕСЛИ(-G2<=45;0;ЕСЛИ(И(-G2>45;-G2<=60);B2*12%;ЕСЛИ(И(-G2>60;-G2<=90);B2*24%;ЕСЛИ(-G2>90;B2*30%))))

slavabatov

#5
Я очень извиняюсь, что пропустил момент, что % годовые, т.е. 12 % годовых за 15 дней из 365.
Спасибо Джим. Вариант г-на Бороды я не понял, точнее не понял, что он считает, поскольку формула не привязана к стоимости вовсе.

Не могу сообразить, как теперь добавить в формулу, что такой то процент считать за конкретное количество дней с 46-го по 60-й, потом процент за конкретное количество дней с 61-го по 90-й, ну и более 90 дней.
ну т.е если дней 70, то 15 дней по 12% годовых и 10 дней по 24 % годовых
а если дней 50 то это 5 дней по 12% годовых.

iron priest

#6
всетаки не удержался

как вы получили за 15 дней 1.8 р. пени?

расчет пени должен быть равен=стоимость*к-во дней просрочки*% / 365

т.е. пеня за 15 дней равна 100*15*12%/365=0,49

slavabatov

Цитата: iron priest от 15.12.2011, 16:52
всетаки не удержался

как вы получили за 15 дней 1.8 р. пени?

расчет пени должен быть равен=стоимость*к-во дней просрочки*% / 365

т.е. пеня за 15 дней равна 100*15*12%/365
Вы абсолютно правы, просто изначально я не правильно изложил условия.

Wasilic

#8
Вот всегда так, тО забыл сказать, это забыл выложить.
А задача из арифметики з-го класса. :)
Так пойдет?
PS. А у Бороды как и уменя, просто рассчитаны проценты.
Достаточно было - стоимость/100*формулу.
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

slavabatov

То что доктор прописал))
Спасибо добрый человек.