Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Вложенные логические функции

Автор clasterit, 23.12.2011, 16:02

« назад - далее »

clasterit

Решал задачу, но столкнулся с проблемой... А называлась проблема логической функцией. Дело в том, что есть условие, которого надо придерживаться, а одной логической функцией тут не обойдёшься. Думал, что решу проблему вложенными функциями, но эта штукенция не хочет обрабатывать числа, которые идут в 3-ей вложенной функции и далее. То есть обрабатывает только числовые значения с первых двух логичных функций(числа от бесконечности и до 229).
Кто подскажет, в чем проблема?
Вот эта ужасная весчь :-\
=ЕСЛИ(A4<=219;A4*0,717;ЕСЛИ(229<=A4>=220;A4*0,684;ЕСЛИ(239<=A4>=230;A4*0,661;ЕСЛИ(249<=A4>=240;A4*0,666;ЕСЛИ(259<=A4>=250;A4*0,64;ЕСЛИ(269<=A4>=260;A4*0,632;ЕСЛИ(279<=A4>=270;A4*0,625;ЕСЛИ(289<=A4>=280;A4*0,612;ЕСЛИ(299<=A4>=290;A4*0,6)))))))))

Serge 007

Цитата: clasterit от 23.12.2011, 16:02
...в чем проблема?
229<=A4>=220 - так условия не задают.

Решение:
=ПРОСМОТР(A4;{219;229;239;249;259;269;279;289;299};{0,717;0,684;0,661;0,666;0,64;0,632;0,625;0,612;0,6})
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

clasterit

Цитата: Serge 007 от 23.12.2011, 16:14
Решение
мне надо логическая функция ЕСЛИ
Вот, табличка
Длина следа
до 219, 220-229, 230-239, 240-249, 250-259, 260-269, 270-279, 280-289, 290-299
Число, на которое умножать
0,717 I 0,684 I 0,661 I 0,666 I 0,64 I 0,632 I 0,625 I 0,612 I 0,6

Serge 007

Цитата: clasterit от 23.12.2011, 16:34
Цитата: Serge 007 от 23.12.2011, 16:14
Решение
мне надо логическая функция ЕСЛИ
Вы мою формулу пробовали?
Она делает то что Вам надо.

ЗЫ Функция ЕСЛИ() допускает только 7 уровней вложения в версиях excel до 12-го релиза (Офис 2007). У Вас какой Excel?
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Wasilic

А в  ЕСЛИ, условие должно быть таким:
=ЕСЛИ(И(A4>=220;A4<=229);A4*0,684;" И ТАК ДАЛЕЕ")
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

clasterit

#5
Пробовал. Что-то не то у меня получилось ::)
Ох, ладно. Как-нибудь разберусь ;)

Кто поможет вот с этой бедой? ::)
файлик добавил. там надо определить ячейку и вставить её содержимое в другую))

Serge 007

Цитата: clasterit от 23.12.2011, 17:33
Пробовал. Что-то не то у меня получилось ::)
Не получилось скопировать формулу с форума и вставить её в файл?! Печально...

Цитата: clasterit от 23.12.2011, 17:33
надо определить ячейку и вставить её содержимое в другую
=ИНДЕКС(A1:A5;ПОИСКПОЗ(МАКС(B1:B5);B1:B5;0))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

clasterit