Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Cравнение двух наборов цифр с отображением результата в виде числа совпадений

Автор Цифровой, 07.01.2012, 09:38

« назад - далее »

Цифровой

Например, есть один набор: 5, 1, 3, 14, 27 и второй: 35, 11, 1, 3, 13. Чтобы сравнило и показало что два совпадения имеется?
Как реализовать, подскажите пожалуйста.

kuklp

Цитата: Цифровой от 07.01.2012, 09:38
Например, есть один набор...
Например у нас - нету. Давайте пример в виде файла xls. И объясните какое надо решение - макросами, формулой. Может у Вас эти массивы на пачке сигарет записаны, а может в листе Экс. Нужно видеть как они расположены. Для общего случая:
=--(СЧЁТЕСЛИ($A$1:$E$1;A2)>0)
Я, как всегда, чертовски адекватен... Email: pilipnikop@yandex.ua WM Z206653985942, R334086032478, U238399322728, E332314026771

kimtan

Ваша задача решается небольшой формулой массива, но как Вам уже написал Сергей (KuklP) эту формулу нужно куда-нибудь ввести...
На всякий случай познакомьтесь с правилами форума.
Webmoney: E350157549801 Z116603216205 R268084006579

Цифровой

kimtan, KuklP , усёк. Картинку сделал...
По той формуле сравнивает с одним числом, но работает, а как сделать чтобы по пять как на картинке?
P.S.  Нуб нубом, я в курсе :-[

Serge 007

И нафига нам картинка? Как Вы себе представляете написание формулы в КАРТИНКЕ?!


=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСКПОЗ(C1:C5;A1:A5;)))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390


MCH