Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Главное меню

объеденение листов, какая формула?

Автор prohorov, 20.01.2012, 12:46

« назад - далее »

prohorov

Добрый день!
помогите пожайлуста, вопрос в чем:
есть таблица, очень большая,много параметров, одно общее- это инвентарный номер (выделен желтым).
внутри 3 листа, на первом - главная, на которой показан конечный результат который должен получиться, инвентарный выделен, он единственный на что можно ориентироваться!!
на 2- сделана выборка диапазона до Р (из 1 листа) с инвентарным
в 3 листе- от Р и до конца, тоже имеет инвентарный с 1 листа

Что нужно:
на 4 листе, посредством некой формулы (если она есть) сделать так, чтобы получился 1 лист, сравнила данные из 2 и из 3 листа и дополнила недостающие данные из 3 листа во 2..
и эти данные которые будут переброшены на лист 2, должны быть выделены цветом.

простите за выражения, но, для меня эксель-сложен, помогите!

Станиславский

можно попробовать вот так.

MozG1983

#2
Если не против, я хотел бы похожий вопрос задать.

Ситуация такова., есть 2 листа один большой 23000, второй 1000
У обоих одинаковые колонки Улица-Дом-корп.-квартира

Нужно в большом списке найти 1000 строк из 2-го списка и отметить их любым символом в пустой колонке в конце списка.(да, истина и т.д. и т.п.)

Спасибо.

Wasilic

#3
ЦитироватьНужно в большом списке найти 1000 строк из 2-го списка и отметить их любым символом в пустой колонке в конце списка.(да, истина и т.д. и т.п.)
Так :)
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

MozG1983

Может я не догнал чего то, но совпадений маловато всего 88, а должно быть 937.(((

в чем может быть проблема???

Wasilic

Да, действительно цикл прерывается.
Не разбирался, сделал простым перебором.
Минут на 5.  :) Однако, совпадений 879.
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

MozG1983

Спасибо. Дейстивельно сопадений ни 937, но это уже можно и руками доделать.

А как исполено все??? просто это не единственный список.

И можно ли тоже самое, но черз функцию выполнить????

_Boroda_

формулы в красных ячейках
Самая быстрая - четвертая, но для нее (и для третьей) нужны доп. столбцы
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

MozG1983

Всем спасибо, за помошь.

вопрос был решен при помоши
=ВПР(F10;'[ОТЧЕТ ПО ПЛИТАМ ГАГАРИН.xlsx]ОБЩИЙ СПИСОК'!$E$2:$H$22345;2;0)

prohorov

спасибо огромное за помощь!!!!! хорошего начала недели!