Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Как посчитать

Автор Ярослав, 24.01.2012, 14:46

« назад - далее »

Ярослав

Есть простая двумерная таблица - список расходов, в которую постоянно добавляются новые строки. Хочу сделать так, чтобы на другом листе автоматически считались суммы счетов по одинаковым расходам. Чувствую, что надо написать макрос, но за малым опытом не знаю как... Может кто подскажет?

Serge 007

Можно и формулами.

В любом случае от Вас ждем файл-пример.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Ярослав

Выложил обрезаный файл... на 1 листе список расходов - он только начался, постепенно станет большим. На втором листе табличка с группировкой статей расходов, напротив каждой статьи в 3 столбце должна накапливаться сумма согласно первого листа...

_Boroda_

примерно так
На листе "Счета" еще проверку правильности ввода статей добавил
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Serge 007

=СУММЕСЛИ(счета!B:B;A3;счета!C:C)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Ярослав

Спасибо! ТОлько не совсем понял как сделали. В формуле слова Статьи и Сумма - под них созданы какие то ссылки? Можете объяснить н апальцах нубу?  :) Стыдно но экселем слабовато владею :(

_Boroda_

Я не стал расписывать потому, что у Вас в книге уже было 2 имени (правда, с битыми ссылками), и я предположил, что Вы знаете, что это такое.
Вкладка "Данные" - "диспетчер имен" - там смотрим, что такое Статьи и Сумма.
Будут вопросы - пишите
ЦитироватьСтыдно но экселем слабовато владею
Если так, то для Вас предпочтительнее формула Сергея
=СУММЕСЛИ(счета!B:B;A3;счета!C:C)
она хоть и весь лист сразу считает - нельзя сказать, что это быстро - но зато понятная.
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Serge 007

Цитата: _Boroda_ от 24.01.2012, 16:37
...у Вас в книге уже было 2 имени, и я предположил, что Вы знаете, что это такое...
Саш, эти имена Excel сам создал ;)

Цитата: _Boroda_ от 24.01.2012, 16:37
Если так, то для Вас предпочтительнее формула Сергея
=СУММЕСЛИ(счета!B:B;A3;счета!C:C)
она хоть и весь лист сразу считает - нельзя сказать, что это быстро - но зато понятная.
Не то что "не быстро", а чудовищно медленно! Сам я таким решением никогда бы не воспользовался, но ты раньше выложил оптимальное :)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Ярослав

Вроде разобрался  :) Спасибо еще раз! Клевый портал