Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Проблема с функцией ВПР из закрытой книги

Автор Джоник, 29.01.2012, 14:02

« назад - далее »

Джоник

Всем доброго дня!
Вот в этой теме :https://forum.msexcel.ru/microsoft_excel/sgruppirovat_dannye_po_art_i_peremestit_ih_v_drugoy_fayl-t7046.0.html, приводятся формулы с использованием ВПР из закрытой книги. Пробую их вставить в живой пример, выдает ошибку. Подскажите пжт, что я не так делаю?
Спасибо!

Джоник

Пардон! Че то файл не крепится?

exceleved

А при открытой Базе работает?
У Вас Excel, пардон, какой? В 2003 и ранее нет функции ЕСЛИОШИБКА.
Попробовал в 2000 формулу без ЕСЛИОШИБКА при открытой Базе:=ВПР($A5;'[База.xls]Тех.описание (2)'!$B:$S;ПОИСКПОЗ(D$3;'[База.xls]Тех.описание (2)'!$B$3:$S$3;0);0)Работает и после закрытия Базы, напротив серых клеток выдает #Н/Д, напротив незакрашенных - состав.

Джоник

Ув. exceleved!
Вы правы, у меня стоит 2003. Вот только ошибку ИМЯ, выдает и при открытой базе. А когда убираю ЕСЛИОШИБКА то #Н/Д в отдельных ячейках, не исчезает и в случае, когда убираю заливку ячеек.
Как с ним бороться?
Благодарю за ответ!

ShAM

В 2003 будет подлиннее. При открытой Базе в ячейку В5. Потом Базу можно закрыть.
=ЕСЛИ(ЕОШИБКА(ВПР($A5;'[База.xls]Тех.описание (2)'!$B:$S;ПОИСКПОЗ(B$3;'[База.xls]Тех.описание (2)'!$B$3:$S$3;0);0));"";ВПР($A5;'[База.xls]Тех.описание (2)'!$B:$S;ПОИСКПОЗ(B$3;'[База.xls]Тех.описание (2)'!$B$3:$S$3;0);0))

exceleved

У Вас в Базе столбец "Состав" может перемещаться?
Если нет, то не надо искать его каждый раз, и формула существенно сократится:=ЕСЛИ(ЕНД(ВПР($A5;'[База.xls]Тех.описание (2)'!$B:$S;4;0));"";ВПР($A5;'[База.xls]Тех.описание (2)'!$B:$S;4;0))

Джоник

Доброго дня!
Первое.
У меня обе формулы работают и с открытой и с закрытой базой.
Но, второе
Как то непонятно переносят даные. Например - не понятно почему появляются пустые ячейки? Ведь в базе в идентичных чейках даные имеются.
Затем, формула: =ЕСЛИ(ЕОШИБКА(ВПР($A5;'[База.xls]Тех.описание (2)'!$B:$S;ПОИСКПОЗ(B$3;'[База.xls]Тех.описание (2)'!$B$3:$S$3;0);0));"";ВПР($A5;'[База.xls]Тех.описание (2)'!$B:$S;ПОИСКПОЗ(B$3;'[База.xls]Тех.описание (2)'!$B$3:$S$3;0);0)) , переносит даные с колонки "ТМ", хотя должна копировать с колонки "ДС/СС".
Спасибо!