Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Как вывести номера строк непустых ячеек?

Автор yakorobot, 08.02.2012, 00:56

« назад - далее »

yakorobot

В столбце A в некоторых ячейках есть текст, в столбец В нужно вывести список с номерами строк непустых ячеек. Как это сделать?


_Boroda_

формула массива
=НАИМЕНЬШИЙ(ЕСЛИ(ЕТЕКСТ($A$1:$A$20);СТРОКА($A$1:$A$20));СТРОКА())
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

yakorobot

А как убрать этот num?

Serge 007

Либо добавить проверку на ошибку в саму формулу, либо условным форматированием
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

yakorobot

ничего не получаеться. еще есть варианты?

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

NooBasTiK

#6
Можно вот так:
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(103;$A$1:A1) - удобно когда списки скрываются или фильтруются
=ЕСЛИ(B2="";"";МАКС($A$1:A1)+1) -  а это просто нумерация заполненных ячеек,но у первой ячейки должен стоять номер в ручную т.е. 1 или другие цифры

NooBasTiK

Формулы протягивать надо, если не получиться то спрашивайте

Wasilic

Цитата: yakorobot от 08.02.2012, 15:15
ничего не получаеться. еще есть варианты?
Есть.
Надо почитать п.2 правил_форума.
Вы считаете, что Вам помогут формулой рисуя ее на картинке?
Так Вам уже рисовали, а у Вас не получается.
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

yakorobot