Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Счет с условием

Автор wolff, 08.02.2012, 21:30

« назад - далее »

wolff

Добрый вечер!
Заранее прошу прощения, если тема повторяется. Поискал, но вроде ни чего подобного не нашел. Необходима формула, которая считала бы количество ячеек в столбце с определенным условием. Во вложенном файле надеюсь всё понятно.
Заранее благодарен.

Wasilic

=СЧЁТЕСЛИ(R[1]C[-1]:R[5]C[-1];">150")
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

wolff

Немного не то. В файле 4000 строк и 70 агентов. Надо чтобы автоматом считало по каждому агенту.

wolff

Диапазон  подсчета по каждому агенту разный, поэтому этот вариант не подходит.

Wasilic

Цитата: wolff от 08.02.2012, 22:31
Диапазон  подсчета по каждому агенту разный,
Введите формулу каждому агенту и укажите в формуле его диапазон.
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

Виктория Зуева

Собственно, Ваша проблема в неправильной организации таблицы.
Я бы сделала ТАК:
(см. вложение)
Это намного облегчает обработку данных.

wolff

К сожалению, Виктория Зуева, Ваш вариант только усложнит. Речь сейчас идет только об одном листе книги, в которой уже есть сводная таблица. А пример этот - всего лишь выгрузка 1С, которая выгружается по вертикали (Агент, а потом клиенты). И перестраивать это в горизонталь тем более не удобно.
Wasilic, я думаю Вы должны понять, что вставлять формулу напротив агентов, у которых каждый день  разное количество клиентов,
по меньшей мере не удобно.
Нужна формула, которая будет считать независимо от расположения агентов и количества их клиентов ( в третьем столбце напротив
агента).

Wasilic

#7
ЦитироватьВ файле 4000 строк и 70 агентов
Цитироватьвыгрузка 1С, которая выгружается по вертикали (Агент, а потом клиенты).
Цитироватьу которых каждый день  разное количество клиентов,
Так почему же, всю эту информацию не выложить изначально?
Мы же не телепаты, чтобы читать мысли на расстоянии.  

PS  Врядли обойдетесь без макроса!
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

wolff

Приношу извинения, что ввел в заблуждение. Но лучше формулой...

Serge 007

Цитата: wolff от 08.02.2012, 23:52
Лучше формулой...
Формулы массива вводятся нажатием Ctrl+Shift+Enter
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

MCH

формула массива:
=ЕСЛИ(B2="";СЧЁТЕСЛИ(B2:ИНДЕКС(B3:B$48;ПОИСКПОЗ(ИСТИНА;B3:B$48="";0));">=150");"")

Wasilic

Ну, тогда и мой вариант.
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

wolff

Друзья, большое Вам спасибо!
Все ваши варианты подходят, по крайней мере их можно подогнать до нужного мне варианта.
Ну и, если можно, еще вопрос на засыпку: предположим во втором столбце напротив агента будет общая сумма
отгрузок по закрепленным за ним клиентам (так обычно выгружаются отчеты 1С), какой тогда должна быть формула? Ведь Ваши варианты, как я понял, ориентированны именно на эту пустую ячейку во втором столбце напротив агентов.

Wasilic

Цитата: wolff от 09.02.2012, 14:44
во втором столбце напротив агента будет общая сумма
отгрузок по закрепленным за ним клиентам (так обычно выгружаются отчеты 1С),
;D  Вы издеваетесь?!!!!

ЦитироватьВсе ваши варианты подходят, по крайней мере их можно подогнать до нужного мне варианта.
Успехов!!!
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

wolff

Спасибо за помощь.