Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Как можно присвоить ячейке значение найдя его таблице

Автор alekswww, 14.02.2012, 14:53

« назад - далее »

alekswww

Подскажите, как можно присвоить ячейке значение найдя в таблице подходящий вариант? На рисунке две таблицы. Хотелось бы чтобы столбец - "уровень существ" нижней таблицы, заполнялся в зависимости от нахождения данных в верхней таблице. Как прописать в заголовках верхней таблицы диапазоны чтобы можно было по ним сравнивать значения в нижней? Возможно ли это вообще? Буду очень признателен за помощь.

Serge 007

Используйте функцию ПРОСМОТР(). Или ВПР(_). Или конструкцию ИНДЕКС(ПОИИСКПОЗ()).
Без примера больше сказать нечего.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

alekswww

Цитата: Serge 007 от 14.02.2012, 15:08
Используйте функцию ПРОСМОТР(). Или ВПР(_). Или конструкцию ИНДЕКС(ПОИИСКПОЗ()).
Без примера больше сказать нечего.

Ну пример такой же как и рисунок. Нужно чтобы в столбце F нижней таблицы записывались значения из верхней, в зависимости какие критерии стоят в столбце D и E нижней таблицы. Я уже находил про ПОИСКПОЗ, но у меня не получилось. Ведь в заголовках верхней таблицы стоят не точные значения, а от и до, больше и меньше.

cheshiki1

проверяйте
=ИНДЕКС($B$4:$F$8;ПОИСКПОЗ(D11;{0;3;11;101;201};1);ПОИСКПОЗ(E11;{0;5;11;21;31};1))

alekswww

Цитата: cheshiki1 от 14.02.2012, 16:16
проверяйте
=ИНДЕКС($B$4:$F$8;ПОИСКПОЗ(D11;{0;3;11;101;201};1);ПОИСКПОЗ(E11;{0;5;11;21;31};1))


Работает :)!! Я правда не совсем понимаю как. Ведь в заголовках значений не точные значения. Большое спасибо :). Сейчас буду разбираться.

alekswww

Разобрался, диапазон искомых значений задан в формуле. Спасибо еще раз.