Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Поиск последней записи по дате.

Автор Sergey Skripay, 14.02.2012, 18:00

« назад - далее »

Sergey Skripay

Имеем файл с таблицей, которая содержит записи по сотрудникам.
На одного сотрудника может быть несколько записей.
Но только одна должна содержать признак, что она последняя (самая новая по дате).
В файле это столбец LastRec (=0 если не последняя запись, =1 если последняя запись).

Как можно формулами высчитать признак самой последней записи (самой новой по дате)?

Более сложный вариант, если этот признак нужно вычислять на определенную дату актуальности.

Может быть кто то сталкивался с подобной задачей.
NULL

Serge 007

формула массива (вводится нажатием Ctrl+Shift+Enter):
=ЕСЛИ(A4=МАКС(ЕСЛИ(Изменения!$C$4:$C$6=Изменения!$C4;Изменения!$A$4:$A$6));1;0)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390