Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Сравнение столбцов

Автор mailman, 16.02.2012, 04:10

« назад - далее »

mailman

Добрый день!
Помогите разобраться с ситуацией.
В таблице 2 столбца их надо сравнить но в обоих столбцах есть за двоения в цифрах использовал формулу =ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(A1;$C$1:$C$1890;0));ЛОЖЬ;A1) но она не запоменает из какой ячейки бралось предыдущие значение так-как каждый раз в новой строке создается. Возможно можно как-то по средствам VBA решить эту проблему но я в нем не разбираюсь.

Станиславский

А если бы пример приложить для наглядности....

mailman


Serge 007

Цитата: Heroboetz от 17.02.2012, 00:50
Пример
Heroboetz, что сделать-то надо? Покажите на примере требуемый итог и объясните почему он такой получился.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

mailman

Надо сравнить 2 столбца A и С в столбец В результат сравнения но чтобы при сравнении значения из столбца С не повторялись. Допустим в столбце А есть 4 значения с одинаковым номером а в столбце С 1 номер при помощи формулы =ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(A1;$C$1:$C$1890;0));ЛОЖЬ;A1) в столбце В на против каждого из значений столбца А получается что все 4 значения есть а по факту в столбце С 1 такое значение.

Serge 007

Цитата: Serge 007 от 17.02.2012, 10:56
Покажите на примере требуемый итог и объясните почему он такой получился.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390