Никак не составить формулу по выводу % среднего значения при условии

Автор pautina13, 21.02.2012, 15:20

« назад - далее »

pautina13

В общем есть данные      
      
1   5   44
4   34   2
3   34   -
15   -   -
2   34   1
      
Что хочу увидеть, если а1<=10 то это 100%, если нет то 0%. Далее общее количество 100% ячеек в заголовки столбце A это 4 одна 0% , нужно вывести среднее значение этих %, т.е. среднее значение по столбцу A 80%, по B это 20%, по C это 40%.       
Ещё нужно учесть ячейки с "-" это тоже 0%      
      
Помогите пожалуйста составить формулу.      

pautina13

проще говоря, нужно из каждого столбца вывести % результатов <=10 

Jim

=СРЗНАЧ(СЧЁТЕСЛИ(A1:A5;"<10")/СЧЁТЗ(A1:A5);СЧЁТЕСЛИ(B1:B5;"<10")/СЧЁТЗ(B1:B5);СЧЁТЕСЛИ(C1:C5;"<10")/СЧЁТЗ(C1:C5))

Wasilic

А так?
=СЧЁТЕСЛИ(A1:A5;"<11")/ЧСТРОК(A1:A5)
Формат ячейки "Процентный"
Может и я на что сгожусь ... Если сгодился, можете меня по+благодарить+.

cheshiki1

=СЧЁТЕСЛИ(A1:A5;"<=10")*100/СЧЁТЗ(A1:A5)  проверяйте. по крайне мере ваши результаты получились, но что то она мне не нравится.

pautina13

Цитата: Wasilic от 21.02.2012, 16:05
А так?
=СЧЁТЕСЛИ(A1:A5;"<11")/ЧСТРОК(A1:A5)
Формат ячейки "Процентный"

Лучший вариант.

Всем всё равно спасибо, очень помогли!