Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Если, где ошибка?

Автор wolff, 26.02.2012, 00:40

« назад - далее »

wolff

Добрый вечер!
Помогите, пожалуйста, разобраться где ошибка в формуле. Файл вложил, там в принципе все понятно.

ShAM

Потому что Вы сравниваете ТЕКСТЫ (на листе 2 у Вас не числа, а тексты). А «7» (как текст) > «35».
ЗЫ: Последнее ЕСЛИ лишнее.

wolff

А почему остальные значения ВПР считывает корректно? В листе 2 значения всегда будут сохраняться в формате текста ( отчет 1С),
поэтому я и выложил файл какой он есть в оригинале. Есть ли возможность, чтобы ВПР все данные считывал правильно? Или пусть
во 2 листе это будет преобразование текстовых значений второго столбца  в числовые значения в 3-м столбце.
Подскажите как это сделать? Менять значения второго столбца во 2 листе вручную не удобно.

Serge 007

Используйте такой вариант:
=ПРОСМОТР(--B3;{0;20;25;30;35};{7200;5000;3500;1000;-1500})
Он не приведёт к ошибке, потому как каждый текст числа преобразуется в настоящее число.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

ShAM

Или сам ВПР превратить в число
=ЕСЛИОШИБКА(--ВПР(A3;'2'!$1:$1048576;2;0);0)
и убрать кавычки с чисел (в 3 столбце).

wolff

Супер! Спасибо за помощь. Оба варианта подходят. Считаю тему закрытой.