Проблема с поиском "суммесли"

Автор STEROID, 12.03.2012, 17:23

« назад - далее »

STEROID

Все в примере =СУММЕСЛИ(B8:B17;B3;D8:D18) не ищет, а когда задаешь значение =СУММЕСЛИ(B8:B17;"*критерий*";D8:D18) - ищет!
Вопрос почему, не могу понять, помогите!!??
Заранее благодарен!

Serge 007

Потому что *К0030297* - это критерий поиска, при котором ищется любое кол-во знаков содержащее К0030297, а B3 - это критерий поиска, при котором ищется точное соответствие ячейке B3.
У Вас в диапазоне B9:B18 нет точного совпадения К0030297, зато есть неточное в ячейке B15: К0030297   (с тремя пробелами после 7-ки).
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

_Boroda_

В ячейке B15 после текста еще 3 пробела
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

STEROID

Понял, спасибо!
Подскажите, а как мне лучше поступить если в столбе b у меня половина значений идут как и B15: К0030297 с тремя пробелами? а вторая половина - нормально!
Как автоматически привести к точному соответствию с критерием поиска (значений много, очень)!

_Boroda_

Можно в соседней ячейке (например, в E2) написать формулу =СЖПРОБЕЛЫ(B2), протянуть вниз, потом скопировать и вставить значениями (через спецвставку) в столбец В
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

STEROID

Спасибо, все работает, ваш ответ очень помог!