Посчитать сумму заказа с помощью ВПР

Автор lazygirl90, 13.03.2012, 14:46

« назад - далее »

lazygirl90

Очень нужна помощь ^^
Задание:
Пересчитать Сумма заказа,руб по курсу в день заказа с помощью функции ВПР.Дата изменения курса ближайшая к дате заказа.
Дата изменения курса валют указана во вкладке справочники

Serge 007

=ВПР(C2;Справочники!$A$2:$B$5;2)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

lazygirl90

Цитата: Serge 007 от 13.03.2012, 15:01
=ВПР(C2;Справочники!$A$2:$B$5;2)

Бооольшое спасибо за помощь! :)

ВЕВ

Добрый день! У меня есть 2 таблицы, в 1-й с помощью ВПР искомые значения попадают из 2-й таблицы, но если точное соответствие не найдено, возвращается значение ошибки #Н/Д. Но дело в том, что потом данный из 1-й таблицы суммируются, но если в ячейке стоит #Н/Д, то суммирование не будет. Можно ли сделать так: если с помощью ВПР точное соответствие не найдено, возвращается значение ошибки не #Н/Д, а 0 (нуль)?

ВЕВ

Вроде получилось: =ЕСЛИ(ЕНД(ВПР...

boa

Цитата: ВЕВ от 21.11.2016, 11:15
Вроде получилось: =ЕСЛИ(ЕНД(ВПР...

в Excel есть удобная функция ЕОШИБКА
например =ЕОШИБКА(ВПР(...);0)
то есть, если ВПР вернет ошибку, то ЕОШИБКА вернет "0" или любое другое значение, которое подставите после разделителя.
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

zs5

С экономической точки зрения советую пересмотреть формулу, так как в случае заказчик последовательно один и тот же, а число заказа пограничное (03.08.07), то надо бы выбрать повыше курс (28,76р.), а представленная формула выбирает не последующий курс, а предыдущий (27,53р.).
Дата изменения курса валют   Курс $      Заказчики
01.08.07   27,53р.      Прибой
04.08.07   28,76р.      Прибой
09.08.07   28,99р.      Борис
11.08.07   29,72р.      
С уважением, ZS.
P.S. ДОВЕРЯЙ MS EXCEL, НО ПРОВЕРЯЙ MS EXCEL

ВЕВ

ВПР(искомое_значение;таблица;номер_столбца;интервальный_просмотр)

Интервальный_просмотр - имеет значение ИСТИНА или ЛОЖЬ. Я правильно понимаю, что в формуле можно указать Истина или Ложь, а можно 1 или 0 соответственно?
И еще, что-то не получается искать по дате, формат ячеек - дата.

IKor

2 BEB

Да, Вы правильно понимаете.
Вероятно в Вашем файле перепутаны форматы дат (где-то проскакивают текстовый формат) - без примера сложно понять причину...
попробуйте принудительно конвертировать даты в "числовой" формат при помощи двойного отрицания "=--A1"