Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Как задать поиск, где результат в том же столбце где и критерий отбора!

Автор STEROID, 20.03.2012, 09:11

« назад - далее »

STEROID

Доброго времени суток!
Как задать поиск в том же столбце, где находится критерий отбора (есть постоянная закономерность, при нахождении критерия отбора - результат поиска находится на ячейку ниже критерия,,помечена красным фоном,,)???

_Boroda_

Где-то так можно
=ИНДЕКС(A$3:A$12;ПОИСКПОЗ($E3;$A$2:$A$11;0))
или СМЕЩ
или ДВССЫЛ
или...
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

STEROID

Спасибо большое, Ваш ответ в примере очень помог, правда не совсем понятен смысл описания "ИНДЕКС" в учебнике EXCEL, обязательно разберусь сегодня на досуге!

_Boroda_

Цитироватьправда не совсем понятен смысл описания "ИНДЕКС" в учебнике EXCEL
Если на пальцах конкретно эту формулу -
=ИНДЕКС(A$3:A$12;ПОИСКПОЗ($E3;$A$2:$A$11;0))
1) ПОИСКПОЗ($E3;$A$2:$A$11;0) ищет номер позиции Е3 в массиве А2:А11 ( в нашем случае это 4 - то есть первый (у нас - единственный) раз К000122 встречается в массиве А2:А11 на четвертой позиции)
2) ИНДЕКС(A$3:A$12;4) из массива А3:А12 вывести четвертое (нашли в п.1) по порядку значение
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

STEROID