Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Возвращение значения в соответствии с текущим часом

Автор nazarenkovlad, 21.03.2012, 11:41

« назад - далее »

nazarenkovlad

Здравствуйте!
Прошу Вас помочь с решением проблемы.
Суть состоит в том, что необходимо в ячейки "Лимит" (I8-I18) на листе "ЧАСОВКА" автоматом присваивать значения лимитов, в соответствии с текущим часом с листа "ЛИМИТЫ" (В8-В18). 0-1 это лимиты первого часа суток,1-2 второй час и т.д. То есть, необходимо каждый последующий час, вносить в колонку лимитов новое значение. Заранее спасибо.....

Serge 007

В I8:
=ИНДЕКС(ЛИМИТЫ!B$8:Y$18;СТРОКА(A1);ЧАС(E8))
и протягиваете вниз
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

nazarenkovlad

Большое спасибо!!!! Всё работает!!!
Единственное, лимит берётся за прошедшую часовку, а не текущую. Допустим на часах 14:15, необходимо использовать лимит из колонки (14-15), а в реале используется лимит из колонки (13-14), как можно это исправить?

Serge 007

Прибавьте единицу :)
=ИНДЕКС(ЛИМИТЫ!B$8:Y$18;СТРОКА(A1);ЧАС(E8)+1)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390