Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Как задать условие

Автор DDiKey, 22.03.2012, 21:29

« назад - далее »

DDiKey

Здраствуйте Ув. форумчане, интересует такой вопрос.

Есть определенный ряд чисел (допустим 1,3,7,12,14,17,21,27,33,35 и т.д.)
необходимо чтобы выполнялось следующее условие: когда я задаю в одной ячейке любое число принадлежащее вышеперечисленному ряду, в другой ячейке должно отображаться число из этого же ряда следующее через одну позицию от заданного, тоесть я ввожу допустим 7, а в другой ячейке должно быть 14, и так далее, как это сделать, буду очень благодарен.

Serge 007

В А1 задавайте число
=ИНДЕКС({1;3;7;12;14;17;21;27;33;35};ПОИСКПОЗ(A1;{1;3;7;12;14;17;21;27;33;35})+2)

ЗЫ А если Вы зададите последнее число диапазона?
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

DDiKey

#2
Нет вводимое число непременно из этого ряда.

СПАСИБО

DDiKey

#3
И еще по ходу появился вопрос как сделать чтоб перемещалось по двум рядам 1;3;7;12;14;17;21;27;33;35
                                                                                                               1;3;7;12;14;17;20;25;30;37

Допустим задаю 21 пошло по верхнему и стало 33, задаю 20 пошло по нижнему и стало 30 соответственно

DDiKey

так что нельзя так сделать или как


ShAM

#5
А если задали 3 или 14 или ..., то по какому ряду искать???
И на вопрос Сергея Вы так и не ответили. Если задается последнее или предпоследнее число, то какое выводить???
Лучше файл приложите с этими числами и с подробным объяснением, что и как делать в разных случаях.