из списка перенести в другой список только цифры

Автор shuh, 27.03.2012, 16:11

« назад - далее »

shuh

как из одной колонки... вытащить только цифры... и в том же порядке их поставить в другой колонке

примерно так

            
            
7         7   
tekst         2   
tekst         3   
tekst         4   
2            
tekst            
tekst            
tekst            
tekst            
3            
tekst            
4            
tekst            
tekst            
tekst            


какую функцию использовать никак не пойму

Serge 007

Цитата: shuh от 27.03.2012, 16:11
какую функцию использовать никак не пойму
А какую пробовали?

=ИНДЕКС($A$1:$A$15;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО($A$1:$A$15);СТРОКА($1:$15));СТРОКА()))

Формулы массива вводятся нажатием Ctrl+Shift+Enter
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

_Boroda_

#2
Вы же раньше просили именно по возрастаниюhttps://forum.msexcel.ru/microsoft_excel/odnu_tablitsu_peresortirovat_v_druguyu-t7510.0.html;msg40245#msg40245
Что-то поменялось?
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

shuh

Цитата: _Boroda_ от 27.03.2012, 17:02
Вы же раньше просили именно по возрастаниюhttps://forum.msexcel.ru/microsoft_excel/odnu_tablitsu_peresortirovat_v_druguyu-t7510.0.html;msg40245#msg40245
Что-то поменялось?

да просил... спасибо вам большое за помощь... но там я поменял диапазон массива и почему то данные не сходятся...тоесть номер стены не шодится с данными... файлик приложил...уже целый день сижу туплю никак не разберусь


(исходный список на первой вкладке lijst ... нужная таблица на второй вкладке converter)

_Boroda_

#4
1) Вы не все 17 заменили на 5
и вообще -
2) нужно было менять не на 5, а на 20
итог
=СУММ((СТРОКА(lijst!$C$21:$C$2000)-20>ПОИСКПОЗ($B6;lijst!$C$21:$C$2000;0))*((СТРОКА(lijst!$C$21:$C$2000)-20<МИН(ЕСЛИ(СТРОКА(lijst!$C$21:$C$2000)*ЕЧИСЛО(lijst!$C$21:$C$2000)>ПОИСКПОЗ($B6;lijst!$C$21:$C$2000;0)+20;СТРОКА(lijst!$C$21:$C$2000)-20;2000)))*(lijst!$F$21:$F$2000=C$5)*ПОДСТАВИТЬ(lijst!$D$21:$D$2000;".";",")))
проверяйте
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

shuh

Борода.... я даж незнаю как отблагодарить вас... столько раз уже выручили... всё действительно сразу заработало....спасибо