Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Как не включать в отчет пустые строки и вывод его ввиде шаблона

Автор ASnake, 11.04.2012, 18:50

« назад - далее »

ASnake

Смыл такой.
Исходные данные:
Лист1 таблица из 4 колонок
--- 1 колонка название, 2 - количество на начало периода, 3 - количество на конец периода, 4 - сумма 2 и 3 колонки

строк может быть разное (но для начала пусть будет фиксировано 100 строк)
в строке всегда заполнена первая колонка остальные могут быть пустые.

Нужно вывести в таблицу на нескольких листах бумаги А4 (на один не помещается)
на каждом листе бумаги вида такие блоки:
название таблицы
шапка таблицы
данные (пусть в том же виде что и таблица на Лист 1(тотже набор колонок и их последовательность)) в данных нужно исключить все строки в которых сумма (4 колонка) равна 0.
подписи к таблице.

т.е. название, шапка и подписи постоянные для каждого листа (если б их можно было запихнуть в колонтитулы :( )
данные переменные.
Прошу помощи в решении, но само решение сделаю сам, подтолкните какой этап с помощью чего делать. Пока кроме VBA решения не вижу, но хотелось бы без него.

_Boroda_

Нули скрываем автофильтром, шапку и подписи в параметрах страницы - вкладка Лист - сквозные строки (для 207/2010 Разметка страницы - Печать зоголовки)
Без Вашего примера - это все, чем могу помочь.
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

ASnake

В принципе ответ очень содержательный и достаточный, спасибо. Осталось через нижний колонтитул прикрутить подписи на каждый лист и все.

А такой вопрос, а можно будет как-то в автомате чтоб перед первой колонкой была еще колонка с нумерацией пунктов, но так чтобы нумеровались только те что отобраны фильтром (не равные нулю).
Думаю какую-то формулу можно, но получается пока только счет идет до перерыва, а потом с единицы опять.
т.е.
имеем

строка10
строка20
строка310
строка45
строка50
сторка67

фильтром отбираем те что больше 0, и оставшиеся нужно пронумеровать

1строка310
2сторка45
3строка67

пока получается только


1строка310
1сторка45
2строка67

_Boroda_

функция ПРОМЕЖУТОЧНЫЕ.ИТОГИ
или в А2 =ЕСЛИ(B2;МАКС(A$1:A1)+1)
или
=ЕСЛИ(B2;МАКС(A$1:A1)+1;"")
и тянем вниз
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

ASnake

Спасибо!
Как говорится, "то, что доктор прописал!" :)