Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Как выбрать из диапазона дат (дата рождения), кол-во именинников на =СЕГОДНЯ()

Автор Студент, 17.04.2012, 12:25

« назад - далее »

Студент

Подскажите пожалуйста, как составить данную формулу? У меня кроме как "счётесли" на дату получилось целое, ни чего другого не приходит в голову  :-\, но том такой сложный случай тогда получается, перечисление счётесли=1, +счетесли=2 и т.д.

ShAM


Студент

Цитата: ShAM от 17.04.2012, 12:54
=СЧЁТЕСЛИ(A1:A100;СЕГОДНЯ())
A1:A100 - диапазон с датами.

Данный вариант был испробован первым, но он же будет считать только именинников 12 года, а мне нужно всех кто родился данного числа каждого года, т.е. 2001, 2002,2003 и т.д.

MCH

=СУММПРОИЗВ(Ч(РАЗНДАТ(A1:A500;СЕГОДНЯ();"yd")=0))
=СУММПРОИЗВ(Ч(ТЕКСТ(A1:A500;"ДДММ")=ТЕКСТ(СЕГОДНЯ();"ДДММ")))
=СУММПРОИЗВ(Ч(ОСТАТ(ДНЕЙ360(A1:A500;СЕГОДНЯ());360)=0))

Студент

Цитата: MCH от 17.04.2012, 14:31
=СУММПРОИЗВ(Ч(РАЗНДАТ(A1:A500;СЕГОДНЯ();"yd")=0))
=СУММПРОИЗВ(Ч(ТЕКСТ(A1:A500;"ДДММ")=ТЕКСТ(СЕГОДНЯ();"ДДММ")))
=СУММПРОИЗВ(Ч(ОСТАТ(ДНЕЙ360(A1:A500;СЕГОДНЯ());360)=0))
Огромное спасибо, две последние работаю отлично, а первая как то не сработала. Но это теперь неважно! Еще раз спасибо.

Тема закрыта!